LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-14-2004, 02:09 PM   #1
Gibsonist
Member
 
Registered: Mar 2004
Location: Meersburg (GER)
Distribution: Cygwin,RH 7.2 7.3, SuSe 6.4 8.2 9.1,TinyLinux, Debian Sarge, Knoppix 3.*, Knoppicilin, Knoppix STD
Posts: 191

Rep: Reputation: 30
Driver modul won't load - CONFIG_MODVERSION in the way


Hi
I am using SuSe8.2 with a 2.4.20 on my laptop.
I recently got a Proxim Orinoco 11 b/g using Atheros.
A friend of mine has the same card and gave me the source for the drivers(MADWiFi).
I compiled them but I cant modprobe them, it always comes up with some unresolved symboles.

the madwifi faq says:
Code:
4.8 The drivers compile fine, but I get "unresolved symbol" errors on modprobe - 
This generally means that your kernel was built with CONFIG_MODVERSIONS set, but the madwifi modules got compiled with different options. Rebuild your kernel with it disabled, hopefully that will fix it.
My problem is SuSe uses a very patchy kernel, I tried recompiling - better compiling 2.6.4 but it isn't running properly on the machine (snd etc not working) - and the drivers load with modprob.

I tried insmod -f ath_pci but it complains bout correct kernel modul not found.

Any ideas for a workaround (heard some suggestion of hexediting the modul)
The joke is I compiled the moduls under the kernel therefore they should be working.

Cheers for any ideas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper, doesn't load my driver ghostbar Linux - Wireless Networking 2 09-15-2005 12:36 PM
Kernel panic on shutdown - Modul-Problems? Fonk Linux - Software 2 03-07-2005 10:18 PM
Cannot load driver Travers Linux - Hardware 0 07-22-2004 02:36 AM
hisax modul Celphi Linux - Software 0 04-21-2004 09:58 AM
How do I load tulip driver? Surfmonkey Linux - Newbie 3 11-21-2003 01:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration