-   Linux - Hardware (
-   -   Driver for NVidia GeForce 4 440 Go? (

digsy 03-24-2003 06:18 PM

Driver for NVidia GeForce 4 440 Go?
Hello, I'd like to know which driver I should get for my GeForce4 440 Go.
I have googled and searched this forum and found some links but I am not sure which one I should download.

I am using RedHat8.0, so should I get "RedHat 8.0 updated to 2.4.18-18.8.0 UP i386 Architecture" from ?

I can see that my card is in supported cards list, but I don't really understand what i386, i586, or i686... are supposed to mean and how I can tell which one is for my laptop.

I understand I am asking a very newbie question, but I don't want to make a mistake again... :o

Thanks in advance.

rmartine 03-24-2003 06:53 PM

Download their NVchooser script. It will tell you what packages to download if you want precompiled rpm's. I think installing the drivers is much easier if you download the source and compile.

digsy 03-24-2003 07:20 PM

Thank you for your reply, rmartine.
I cannot run that script for some reason, I have tried downloading with Mozilla and Konqueror, also tried renaming to bin, didn't work..
Do I have to open it with any program, or just double-clicking?

P.S. I don't even know how to complie, I'm a total newbie. ;)

digsy 03-24-2003 07:58 PM

Never mind, I figured how to run that scrript.
I'm going to download the driver, wish me luck! ;)

rmartine 03-24-2003 08:19 PM

Good Luck.

You may run into some problems later with the evil "black bar" once you get everything rolling. Just keep at it.

digsy 03-25-2003 01:43 AM

I finally got it working thanks to a tutorial I found on this forum!
But there's a vertical black empty space on the right side of my monitor now, is this what you meant by "black bar"??
And everything is a bit blurry now.
But I could play TuxRacer! :p

rmartine 03-25-2003 02:01 AM

Yup... that's the black bar I was talking about. If you look around there isn't much info on how to make that thing go away. I have a Toshiba laptop so I'm going to give you the settings for mine. Dells use something a bit different. So.. I hope you're using a Toshiba :)

You need to add a line to /etc/modules.conf. So cd /etc and vi modules.conf. You need to be root to do this. Look for an alias line. Somewhere in there you should see something that reads either alias blah blah nvidia or NVdriver. It's one of the two.

Add this to end of the file.

options nvidia "NVreg_softEDID's=0" "NVreg_Mobile=2"

Like I said above, if you see alias nvidia add options nvidia yadda yadda. If you see NVdriver add options NVdriver yadda yadda

One of the two values (0 or 2) is manufacturer dependent and I can't remember which. Somewhere in the driver manual toward the bottom you can get the value. The line I showed you isn't explained in there very well.

digsy 03-25-2003 02:25 AM

Yes, my laptop is Toshiba Satellite 5105-501.
Thanks a lot for sharing your tip, I'll try it tomorrow if I have time and tell you if it works. :)

digsy 03-25-2003 06:38 PM

This is my current modules.conf

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci
alias char-major-195 nvidia
So I should add the line you told me and it should look like this?

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci
alias char-major-195 nvidia options nvidia "NVreg_softEDID's=0" "NVreg_Mobile=2"

digsy 03-25-2003 06:49 PM

If you don't mind, could you post your display setting?
I'd like to know your Resolution, Color Depth, and Monitor Type.
Everything is blurry no matter what setting I choose after installing NVidia's driver.

rmartine 03-25-2003 07:55 PM

Sorry if I wasn't clear. The options line goes under the alias line.

alias usb-controller usb-uhci
alias char-major-195 nvidia

options nvidia "NVreg_SoftEDIDs=0" "NVreg_Mobile=2"

I'm running 32 bit at 1024x768 on a 15" monitor

rmartine 03-25-2003 07:56 PM

My bad. Also the ' doesn't belong there. What I showed you is from my modules.conf file.

digsy 03-25-2003 08:09 PM

Whoa, it worked like a charm!
Now everything looks clear!
Thank you again, rmartine! :D

P.S. I didn't know you could run at 32 bit, I can only choose from 256 colors, 15 bit, 16 bit, and 24 bit.

linux_GNUbie 03-26-2003 11:19 AM

Could you guys post your .conf files here? Or send it to me?
I am also trying to configure the nVidia drivers for my
Toshiba laptop and I'm still having problems with the
settings. I followed the tutorial on this forum--great stuff!--
but the settings are incorrect.
I have the Toshiba Satellite 2435-s255
nVidia Ge-Force4 420 Go controller

Thank you!


rmartine 03-26-2003 02:39 PM

Cool. I also have a Gefore 4 420 Go. What exactly is the problem? The important part of my modules.conf file is posted above.

Are you at the black bar yet? Does nvidia pop up when you startx?

All times are GMT -5. The time now is 12:01 PM.