-   Linux - Hardware (
-   -   does linux support the sata raid and ide raid in k7n2 delta ilsr? (

spyghost 03-26-2004 09:45 AM

does linux support the sata raid and ide raid in k7n2 delta ilsr?

i am planning to setup both my regular ide's and sata as raid 0. before i begin i buy a new set of hard disks i just want to make sure if linux (i am open for suggestions for any distro) supports both on-board raids...

what linux distro can support both on-board raid functions of my mobo (k7n2 delta ilsr)


siddiqu 03-26-2004 10:48 AM


Mandrake 9.2


spyghost 03-26-2004 07:53 PM

really? that's great... have you tested it?

hw-tph 03-26-2004 08:13 PM

That's an nForce2-based board, right? From my own experience and from what I have read - no, I wouldn't count on it. The Sil3112 controller is supported as an IDE controller in Linux, and in later versions also under SCSI emulation, but I don't think hardware RAID is supported. You will most likely have to resort to logical volume management / software RAID.


Pwnz3r 03-26-2004 08:38 PM

Sorry to burst your bubble hw-tph, but this is the exact same board that I use and as long as you compile the module for the promise SATA drivers then it will work. I have no SATA drivers, but during the kernel boot it recognizes both SATA connections.

Linux has had support for RAID for a quite a while, and the 2.6.4 kernel will definately support it.

As for the distro, I highly reccomend using Gentoo. It's only $10 to buy (which includes the two Live CDs and the installation manual) and it's extremely customizable along with being able to fit any application that you need it for, whether it be for a workstation or a server PC. It's free to d/l if you have the bandwidth like I do. ;)

Mandrake is a highly expensive distro, unless you d/l it for free, and runs across a lot of dependencies errors whereas the Portage system in Gentoo will get all the dependencies and compile them before the target package so that you don't have problems.

I have a friend that uses Morphix and he says that it is good as well. I say if you want a good distro with an easy install that's small and doesn't put you through dependency hell then use Morphix. If you want a distro that you can fully customize and which also won't put you through dependency hell then get Gentoo. If you want a lot of headaches then you can use Mandrake, but it really is a pain in the ass sometimes. (Mandrake 9.2 is what caused me to make the switch to Linux, and it gave me a lot of headaches with dependency problems when installing things from the source and from RPM's. Not to mention, Mandrake causes many problems by never giving the kernel sources which are very important. :()

I don't think that Red Hat's any better when it comes to dependencies either, but it might be. The moral of the story is use Gentoo or Morphix if you want a good time.

hw-tph 03-27-2004 03:36 AM

Pwnz3r, that's interesting so I might get another 120GB SATA drive and give it a ty. If you set up hardware RAID, what is the RAID device that Linux recognizes called?


spyghost 03-29-2004 11:01 PM

gentoo and morphix... hmm... sounds good... let me d/l them both and test them... :-) i'll keep you all updated of the results...

spyghost 03-30-2004 02:45 AM

btw, where can i get the promise sata drivers?

slartibartfasz 04-16-2004 03:42 AM

Pwnz3r - you are my man :D

i'm currently trying to install gentoo on the k7n2 with a single 80GB maxtor SATA disk - unfortunately i cant find the drive when booting from the 2004.0 gentoo installation cd.

i tried to boot with various kernel options but i cant seem the find the drive (as /dev/hd*, /dev/sd* or /dev/at*) even though gentoo says 'Dedected raid hardware' during the boot process.

how do i go about this?

hw-tph 04-16-2004 04:35 AM

I believe that if you use the doataraid option during boot you will get the RAID setup as /dev/ataraid/disc0. If you have problems you might want to try this approach.


slartibartfasz 04-16-2004 06:27 AM


Originally posted by hw-tph
I believe that if you use the doataraid option during boot you will get the RAID setup as /dev/ataraid/disc0.

I tried that - no luck unfortunately :( Do i need to en/disable anything in the BIOS or is it just not supported under gentoo 2004.0? The cd uses a 2.4.24 kernel - unfortunately compiled with gcc3 - so the driver does not work because it is compiled with gcc2


Originally posted by hw-tph
If you have problems you might want to try this approach.

Thanks a bunch for the link - its definitely an interesting approach - the problem is that knoppix does not know the ethernet card (onboard) - AHRRG

Two other possibilities come to my mind:

1) try to compile the medley.o driver from the sources booting of the gentoo 2004.0 cd

2) use a development version of the gentoo cd - 2.6_11 is the newest i found

any recommendations or ideas?

All times are GMT -5. The time now is 03:51 AM.