-   Linux - Hardware (
-   -   Dlink dwl-650+ Driver (

iksnizal 12-17-2002 12:35 AM

Dlink dwl-650+ Driver
Hi, I am a Linux Newbie and I am having quite a few issues with the Dlink dwl-650+ 22mbs Wireless Card. The card is based on the TI ACX100 chipset and no official driver has been released. However, according to Melbourne Wireless ( the Dlink 22mbs card is a rebranding of a Global Sun Tech card and that many other OEM's use the same Chipset. Melbourne wireless then states that a Linux Driver can be obtained at :

I admit, I am new to Linux, but I follow the step by step doc that comes with the driver and I run a test as per the instrucions:

"insmod acx100_pci.o"

I then receive an error stating the module I am trying to run was compiled with a GNU 2 compiler and I am running a kernel compiled with GNU 3 and this is known not to work...

Can anyone help me out with this one? I would really like to get this wireless card working so I can keep learning Linux without wires... ( I have twin 2 year old daughters who happen to love to pull on wires)

Any Help would be appreciated.


mdh 12-17-2002 01:50 AM

Okay, what distro are you using???
Which version of GCC have you got? (gcc --version) I'm assuming its 2.95.x

Best bet is to get a copy of the gcc-3.2.x package for whatever your distro is (rpm for redhat, deb for debian etc) install it and rebuild the module with the new gcc.

finegan 12-17-2002 07:14 AM


I downloaded the package linked, they provide a binary only driver, and if I remember my versions right, its only going to properly insmod in the kernel provided with Mandrake 8.2.

It also uses the configuration and control utilities from the project, which aside from being the first tools out there, are clunky and not part of the standard kernel wireless extensions... although they do tend to work blindingly well.

Also, from the two MS word formatted documents that were provided with the file... it seems that whomever put this together know about as much about Linux as I do about nuclear physics. The module might have a chance of being insmoded into something other than the 2.4.18-6mdk stock kernel from 8.2 had it not been for the fact that they compiled it with version symboling. As it stands, that won't eve insmod into my Slackware 2.4.18 stock because of that goof...

All in all, this is kind of galling.


Impecable homework, but unless you want to install mandy 8.2, it looks like you're going to have to track down the source code, possibly an email to whomever maintains that site. As it stands, Jean's page on wireless devices is almost always current and has these devices mentioned as entirely unsupported, so you may have found some source in the wild.



iksnizal 12-17-2002 10:36 AM

Afraid of this...
I figured it wasn't going to be easy. I am a total newbie to linux and I am running Redhat 8.0 and added the RPM for kernel 2.4.18-18.8.0. I have no experience with GCC and very little with programming, but I have to start somewhere :study: . I will see what I can do as far as getting the source code and if I can figure out how to use GCC. I figured from the error that it needed to be recompiled but I did not know if that was possible and where I should begin doing that.

Dlink is supposed to come out with a driver for this in the near future; possibly in December or first quarter 2003. I would really like to get it working though so I wil pursue it until I no longer have to, or until I decide to throw some money at the problem and get a decent wireless card that is already supprted.

Any other ideas out there? Maybe even a super secret beta driver or something?;)

finegan 12-17-2002 09:15 PM

No man, that's all, if I knew about a driver for this chipset, I would have a link to it in my bookmarks... there are I think 4 companies producing cards built on this software acceleration ramping that TI created. TI is stodgy with documentation so open source developers don't really get a chance to develop modules... its just that tough.

building from the source is probably going to be ridiculously easy:

cd sourcedir-dwl650
make install
insmod somemodule.o

Usually that's it! The makefile does most of the work.



rsbecker007 01-09-2003 07:28 AM

See here for my experience with acx-100 and DWL-650+

TI is the root of the problem to summarize...

mdh 01-09-2003 05:53 PM

Arghhh, well thats one way to reduce your market share I suppose :-) At least Nvidia with their closed source drivers provide for the majority of distros, promise as well to a lesser extent...
There's a simple solution, don't buy them/return them
Let the companies know why you aren't buying their hardware (preferably with a link to a posting on a high volume entertainment/news/technical site, like this), only community pressure (with a threat to their bottom line/reputation) will force them to cater to more than the M$ world, methinks they support only one distro just so they can say "we run on linux".

aaz 02-01-2003 07:50 PM

I have Mandrake 8,2 and these versions of Acx-100 driver,
when executing the command "insmod" i obtain these errors,

# insmod acx100_pci.o
Result: acx100_pci.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters.

# insmod acx100_pci-2.4.19.o
Result: acx100_pci-2.4.19.o: unresolved symbol zone_table

in truth not like correcting them if somebody knows of some solution
serious me of much aid.

Thousand thanks!

finegan 02-01-2003 09:04 PM

This is a stock install of Mandrake 8.2, without any kernel upgrades? What do you get from:

uname -r

If its not 2.4.19-mdksomething, you've got the wrong version of the kernel for the driver... which is a little odd. Also, despite the head of this thread, that module is only properly going to work with the PCI version of this card, the DWL-520+



aaz 02-04-2003 06:35 PM

It's not working!!
More questions about this driver:
The driver that it has worked that version is?,
on which computer architecture works?, that is to say, that operative platform you have?,
and that version of Mandrake kernel you have?.

It is that I previously carry out all the described steps and does not even work correctly.
If you can help me it is of great value.

If it is much to request you can referenciar the file to me that contains driver. :)

Or how much cost this version? :D

aaz 02-06-2003 08:58 AM

It obtains that works the driver in Mandrake 8,2 with kernel 2.4.18-6mdk and already works well.

Correctly following the instructions of the manufacturer.


skoorbevad 03-12-2003 12:12 PM

Where are you guys getting the ACX-100 driver?!
I've looked high and low, and I see fleeting mentions of such a thing in posts like this, but the links provided to download do not work. I've got a DLink DWL-520+ card that's ACX-100 based, but DLink's page (obviously) says that there are not any drivers out for that card, currently.

But yet, people on this forum somehow have gotten their hands on the ability to compile an acx100_pci.o module? Where can I get such a thing?! :)


finegan 03-12-2003 12:47 PM

We've never had the ability to compile the module, just 2 precompiled binaries that a taiwanese manufactuer put up. They're for 2 different glibcs. They got a spanking from TI for possible NDA violations, so it got pulled from their site:

rsbecker has them linked off of that page.



mdh 03-13-2003 12:05 AM

Anyone else feel the need to fire up REC and lose a few weeks of their lives?

Wonder if the debug symbols have been left in the modules or not...

Damned closed source drivers :-/
Not all of us are slaves to mandrake/redhat

rmartine 03-13-2003 12:42 AM

This is funny... I had that same card and finally sold it to a friend who uses XP. I bought a Netgeat MA401. It's actually a 401RA when you run cardctl ident. Just bind the thing to orinoco_cs and you're done.

Good Luck

All times are GMT -5. The time now is 04:17 AM.