-   Linux - Hardware (
-   -   disabled keyboard and touchpad on notebook (

paalmarker 10-04-2007 05:22 AM

disabled keyboard and touchpad on notebook
I have 6 notebooks, fujitsu-siemens amilo pro v2055. They have the same configuration all. Slackware 12 with the default kernel smp.

Randomly, average about one out of five boots, the laptops keyboard and mouse is dead and disabled after boot. The problem is similar on all six notebooks. Doesn't matter if inittab is set to init 3 or 4, wich leaves out misconfigurations in xorg.conf.

Booting with usb keyboard and mouse works perfect.

I wrote a script to make an output of dmesg for each boot, and had then one output for boot=ok and one for dead keyboard and mouse.

by #diff dmesg.output1 dmesg.outout2 I get 101 lines difference.

First line that differ is:

input: AT Translated Set 2 keyboard as /class/input/input2

This line doesn't excist in the dmesg from boot with dead keyboard, so this seems to be relevant. but what to do from here? Searching up the line on google just leads me to lots of dmesg dumps about problems that has no relevanse.

Anyone experienced this with fujitsu siemens notebooks?
It is very strange that this happens randomly, most of the boots goes perfect. The problem occure from both power-up boots and reboots.

kaz2100 10-04-2007 09:46 AM


It looks like frustrating situation.

I personally do not have Fujitsu-Siemens ones, so following is I would do if I had your penguin.

Read documents of kernel source file, looking for fujitsu and/or siemens as a keyword. and check if any kernel parameter (boot parameter) and/or config option could solve your situation. Also check bios.

Hope this helps.

Happy Penguins!

paalmarker 10-05-2007 02:46 AM

Thanks for answer

Bios I am sure I can leave out here, notebooks keyboard allways on every boot works when I come to LILO. The notebooks have been tested wih all kind of boots, sometimes I have seen that I can use keyboard key to cancel lilos timeout, when I come to login the keys don't work

I could not find any specific relevant comments in the documentaion either.

paalmarker 10-05-2007 03:34 AM

Ok, have now written a script to go after each boot that will give me an output of lsmod and lspci as well. As soon as a boot comes with disabled keyboard it may tell me something by run diff towards a output when boot was ok

paalmarker 10-08-2007 03:44 AM

This monday morning one of the notebooks booted with disabled keyboard/touchpad. I have configured the notebooks to give output to file from dmesg, lspci and lsmod automatically after boot. I rebooted the notebook, and after boot keyboard and touchpad worked ok. I generated my script to give new output files, so I have output files from both boots.

Running diff for lspci files showed they were identical, wich was expected.

Running diff for dmesg files gives the same result as described in previous posting.
The line "input: AT Translated Set 2 keyboard as /class/input/input2" was missing after failed boot.

Running diff for the two outputs of lsmod showed that the same modules were loaded. But the modules are listed in different order.

Do I have a clue here??

I do not know the default listing order of the lsmod command, but I can not believe that the listing order output is random. The two different outputs from lsmod is both from approx 5 minutes after boot. Absolutely no configurations done between boots.

If anyone on the forum wants to investigate this problem I can post the output files.

paalmarker 10-08-2007 08:08 AM

Found at last a bug report on this issue:

Unfortunately it seems to be unsolved, has not been edited since july. Though I will try the tip of pathing DSDT into the kernel.

Nevertheless I have made a rather heavy workaround. The notebooks are located as kiosks in a library for public search in librarys media-database, they are to reboot every morning before opening time and they do not need to be turned off during the day.

What I know is that from the dmesg output, the line "input: AT Translated Set 2 keyboard as /class/input/input2" will be missing on failed boot. The problem occures randomly, average one out of five boot-ups. So having a perl program that loads the output of dmesg into a variable, another variable using grep "input: AT Translated Set 2 keyboard as /class/input/input2" on the first variable. If it returns zero, then reboot, if it returns value, do nothing.

Not very elegant solution, if anyone can give me a tip of a better way I will be happy...

I have put the outputs from dmesg, lsmod, and /var/log/messages here:

cheesus 10-24-2007 04:44 PM

Hello, my girlfriends fujitsu siemens amilo laptop shows the same
behaviour: On about 1 out of 3 reboots, the keyboards is dead.

In this case, I cannot even switch to the boot messages by pressing
ESC, so it is dead before X is started...

This is a vanilla SuSE 10.3 DVD install with all current patches
installed. (Oh, and 10.0 ran ok for over a year...)

Anyone who makes progress here, please post.

I also have the (new) problem that poweroff will do a reboot
instead of a shutdown. Will try apci=off with that. Any chance
these things could be related ?


cheesus 11-26-2007 04:08 PM

no idea why, but switching to fedora 7 helped.
Installed Fedora 7, no problems whatsoever. ;-)

Maybe it's just because of the older kernel, so now I'm afraid
to install the security patches... :-/


All times are GMT -5. The time now is 02:01 PM.