LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Disable keyboard to wakeup my computer. (http://www.linuxquestions.org/questions/showthread.php?t=4175443916)

miros84 01-03-2013 01:57 AM

Disable keyboard to wakeup my computer.
 
How can I disable that keyboard can wakeup my computer.
I want to be wake up only by mouse.

I use Debian Wheezy.

trevoratxtal 01-03-2013 02:04 AM

Wake up on-----
 
I think that is a Bios setting and may or not be in your computer,
If you have problems getting to your Bios please come back.
It is something that happens long before Linux Kernel is awake, unless some one can tell me otherwise.
Trev

miros84 01-03-2013 07:17 AM

I dont think so.
In Windows, you can set which devices can wake or not the computer when it suspend.
Going to device managager, but in Linux? How can I disable or enable which devices can wake it up?

trevoratxtal 01-03-2013 09:10 AM

Wake up
 
wake up from keyboard/mouse/lan is a part of Bios and works from cold start.
Whereas
You require wake up from Sleep that is different as the operating system is already running only on hold.
As I do not wish to use Windows it is not in my experience so I cannot help sorry.
Trev

miros84 02-06-2013 04:56 AM

Somebody else? I can disable keyboard in Windows in device manager and prevent to wake up the computer.
What about Linux?

TobiSGD 02-06-2013 07:46 AM

trevoratxtal is right, usually this is a BIOS setting (Windows is able to interface with your BIOS, for example to set a wake-up alarm time). I would look there first.

Pastychomper 02-07-2013 10:10 AM

If you're talking about 'sleep' as in suspend to RAM rather than 'hibernate' (suspend to disc) then there is a way to do it in software. I know because when I upgraded from Lenny to Squeeze I lost the ability to wake by keyboard, but can still wake by pressing the power button. I made no direct changes to the BIOS in that time. I even had the two versions dual-booting for a while - Lenny wakes from keyboard, Squeeze does not.

Unfortunately I don't know what the difference is, so can't help there.

miros84 02-11-2013 09:58 AM

Yes, I am talking about suspend in memory. I looked in Bios but keyboard suspend is disbled. I tried to enable but it was the same. Computer wake up when somebody touch the keyboard.
I put it in disalbe again. Must be some software way to change that. Something in kernel or config file somewhere, but I dont know what to change there. If somebody has any idea?...


All times are GMT -5. The time now is 06:57 AM.