-   Linux - Hardware (
-   -   /dev/sda2 gone?? (

bmayersohn 12-26-2005 08:02 PM

/dev/sda2 gone??
I recently received a 30G iPod for the holidays, and although I had some trouble getting it to work on linux the first time around, everything eventually fell into place. However, my iPod used to mount on /dev/sda2 when it worked, but now the device seems to have disappeared from the /dev folder. There are no sda devices at all, and I have no clue where they went. I've unmounted it and remounted it several times yesterday, and this never happened before. Please help!

ramram29 12-26-2005 08:31 PM

What type of version of Linux are you using? Most of the newer versions use UDEV - a kernel device manager that loads only the necessary drivers detected. For example, Fedora 3 and up use UDEV. I can see the /dev/sdc1 driver appear and disappear when I plug in my USB external hard disk. Try restarting your PC then run "dmesg | grep sdc" to see it loading on your logs then mount it and umount it as necessary.

bmayersohn 12-27-2005 09:13 AM

I use Ubuntu Linux Breezy Badger. Strangely, after I shut down for the night and booted into Ubuntu today, all of the sda devices returned. It always mounted on sda2, so dmesg | grep sdc didn't show any results. However, I changed sdc to sda and it detected the iPod as expected:

bmayersohn@ubuntu:~$ dmesg | grep sda
[4294714.268000] SCSI device sda: 58605120 512-byte hdwr sectors (30006 MB)
[4294714.269000] sda: Write Protect is off
[4294714.269000] sda: Mode Sense: 6c 00 00 08
[4294714.269000] sda: assuming drive cache: write through
[4294714.303000] SCSI device sda: 58605120 512-byte hdwr sectors (30006 MB)
[4294714.304000] sda: Write Protect is off
[4294714.304000] sda: Mode Sense: 6c 00 00 08
[4294714.304000] sda: assuming drive cache: write through
[4294714.671000] Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0

However, whenever I eject the iPod, the sda devices all disappear and I can't find a way to remount them. I think this was the problem in the first place.
[/dev/ipod is a symbolic link to the correct sda device]

sudo mount -t vfat /dev/ipod /media/iPod
mount: special device /dev/ipod does not exist

The volunteers who take their time to help others are greatly appreciated. And thanks to ramram29 for that last reply!
EDIT: I unplugged the iPod even though it said "Do Not Disconnect," and replugged it, and that seemed to do the trick. Is there was a more proper way to do this?

ramram29 12-28-2005 10:53 PM

Try this:

-Login as root.
-Run 'dmesg | tail'
-You should see the last 10 lines of your message log.
-Connect your ipod.
-Wait 10 seconds.
-Run 'dmesg | tail' again and notice if the last 10 lines of your message log changed to reflect the detection of the USB drive.
-Run 'tail -n 100 /var/log/messages | grep sda'.
-From the bottom up you should see the sda device that was linked to your USB drive.
-Create a temporary mount folder by running 'mkdir /mnt/tmp'.
-If the device is sda2 like you said then to mount it run 'mount /dev/sda2 /mnt/tmp'.

-Make sure you unmount the device before you unplug it; run 'umount /mnt/tmp'; otherwize you may get unexpected results unless you are running the automounter deamon.

bmayersohn 12-29-2005 01:32 PM

Alright, I think I solved my problem. I had already set up a link to the device in /media/iPod and I always made sure to umount it. I followed the instructions from the README on the gtkpod homepage, and i used another site as a guideline for setting up scripts that gtkpod uses to manage the iPod. Now the only annoyance is that sometimes gtkpod crashes, and it interrupts the process of umounting and ejecting the iPod, leaving that nasty Do Not Disconnect message in play. I don't know why it crashes, but it's not much of a problem considering I got the iPod working in the first place. Thanks ramram29 for being responsive as usual!

All times are GMT -5. The time now is 02:19 AM.