LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   /dev/sda1 not valid block device (https://www.linuxquestions.org/questions/linux-hardware-18/dev-sda1-not-valid-block-device-149158/)

abs 02-24-2004 01:14 PM

i've got the same problem but with /dev/hda. it was working fine before except for this one time when it didn't. i had compiled a kernel. i just restarted and it worked. so i doubt it's a kernel issue. it's happening again now again, with another kernel. i doubt it's even a driver/module issue, but just to let ull know, the fs modules were included (vfat). why does this happen anyway? (works most of the time)

JaseP 02-24-2004 04:48 PM

I have a similar problem with a SanDisk Cruzer Mini 128 running on SuSE 8.2 with a 2.4.20 kernel.

On my desktop machine, I can get the thing to mount, but on the laptop machine I have, it hangs trying to mount. When I do a dmesg, I see that the thing is being assigned to /dev/sda1,... but it won't mount no matter what I do.

Frustrating. I can only assume it's a chipset related bug thing with USB services...

abs 02-25-2004 01:38 AM

so u're saying that the usb module (hotplug one) is causing the problem? i have installed that too. anything else common to systems with these probs?

abs 02-29-2004 04:08 AM

after a restart, it started reading the disk just fine. no idea what's causing this issue.

pcpinkerton 02-29-2004 08:48 AM

After upgrading to 2.6.3 the problem continued however I made the following changes :

1) removed the scsi emulation from the kernel
2) re-boot with the usb_storage device off
3) ran modprobe usb_storage
4) ran modprobe usb
5) lsmod

Module Size Used by
sd_mod 15648 2
uhci_hcd 28688 0
sg 36256 0
usb_storage 94992 1
scsi_mod 111416 3 sd_mod,sg,usb_storage
snd_pcm_oss 49188 0
md5 4096 1
ipv6 222016 6
psmouse 17800 0
parport_pc 37036 1
lp 11692 0
parport 39912 2 parport_pc,lp
3c59x 37416 0
quota_v2 8704 0
snd_mixer_oss 16896 1 snd_pcm_oss
snd_emu10k1 82180 1
snd_rawmidi 22944 1 snd_emu10k1
snd_pcm 89480 2 snd_pcm_oss,snd_emu10k1
snd_timer 23300 1 snd_pcm
snd_seq_device 8072 2 snd_emu10k1,snd_rawmidi
snd_ac97_codec 55300 1 snd_emu10k1
snd_page_alloc 11908 2 snd_emu10k1,snd_pcm
snd_util_mem 4608 1 snd_emu10k1
snd_hwdep 8964 1 snd_emu10k1
snd 49380 12 snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,sn d_util_mem,snd_hwdep
soundcore 9056 1 snd
agpgart 30248 0
rtc 11576 0
ext3 106152 2
mbcache 8324 1 ext3
jbd 53272 1 ext3


6) turn on usb_storage device
7) ran cdrecord -scanbus ( only way I know to see scsi devices address)
scsibus1:
1,0,0 100) 'IC35L090' 'AVV207-0 ' 'V23O' Disk

At this point I still could not mount /dev/sda1 /mnt/usbhd ? HOWEVER !

I tried this next :

8) fdisk /dev/sda1

There was a message about block 0 that would be corrected with a "write" before
leaving fdisk. ( sorry for not coping the message) Well this always freaks me out so I just quit fdisk instead. When I quit fdisk the light flashed on my usb_storage disk so I tried mount /dev/sda1 /mnt/usbhd again. AND IT WORKED !!

I can only guess something weird was written to block zero at some point and prevented me from mounting the disk. I won't know if it was a complete success until I try to re-boot with the mount /dev/sda1 parameters in fstab

Any how for now my system is running 100% on kernel 2.6.3 Just need to figure out how to load the modules on boot instead of running modprobe manually. I think there is a module.conf file that takes cae of this.

Philip


All times are GMT -5. The time now is 01:52 AM.