-   Linux - Hardware (
-   -   /dev/dvd is /dev/cdrom? (

babysealclubber 10-31-2003 08:31 PM

/dev/dvd is /dev/cdrom?
mount /dev/cdrom /mnt/cdrom

That's just great.

But mounting /dev/dvd to a mount point mounts the cdrom device, not the dvd device.. what gives? How do you mount a DVD?

kilgoretrout 10-31-2003 10:56 PM

/dev/dvd is just a link to a true hardware device. Do:

$ ls -l /dev/dvd

to see what it links to. The reason for the link is that many programs that play dvds look for a /dev/dvd by convention. /dev/dvd should link to the /dev/hdx that is your dvd drive.

glennardo 10-31-2003 11:16 PM

Re: /dev/dvd is /dev/cdrom?

Originally posted by babysealclubber
mount /dev/cdrom /mnt/cdrom

That's just great.

But mounting /dev/dvd to a mount point mounts the cdrom device, not the dvd device.. what gives? How do you mount a DVD?

or d'ya mount somethin' like
as root :
#ln -s /dev/cdrom /dev/dvd


babysealclubber 10-31-2003 11:23 PM


mount /dev/cdrom /mnt/cdrom


mount /dev/dvd /mnt/dvd
Both do the same thing.


bash-2.05b$ ls -l /dev | grep dvd
lrwxrwxrwx    1 root    root            8 Oct 29 23:05 dvd -> /dev/sr0
bash-2.05b$ ls -l /dev | grep cdrom
lrwxrwxrwx    1 root    root            8 Oct 29 23:05 cdrom -> /dev/sr0

And that's why. Does anyone have any idea what the device actually is?

quatsch 10-31-2003 11:30 PM

hte link target says it. It's /dev/sr0 on your machine. It's one and the same drive, right? So it's no puzzle.

kilgoretrout 10-31-2003 11:39 PM

/dev/sr0 is usually another link to /dev/scd0 so you have a double link going which is not all that unusual with cdrom devices:

/dev/dvd --> /dev/sr0 --> /dev/scd0

Check it with:

$ ls -l /dev/sr0

Ultimately you'll get back to a hardware device you recognize, here, /dev/scd0 a scsi emulated cd drive.

babysealclubber 11-01-2003 12:35 AM

But only hdc is scsi emulated. hdd is my DVD drive. They should be seperate devices. Both cdrom and dvd point to sr0.

bash-2.05b$ ls -l /dev/sr0
brw-r----- 1 root disk 11, 0 Apr 12 1999 /dev/sr0

sr0 doesn't point to anything else.

bash-2.05b# mount -t auto /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only

This mounts my cdrom. scd1 doesn't exist because I don't have the DVD drive scsi emulated.

The DVD drive device has to exist somewhere. I don't see why both dvd and cdrom are symlinked to the same device when they're two seperate devices.

quatsch 11-01-2003 12:40 AM

do you have two physical drives or is it a combo drive?

If you have separate drives, you can link /dev/dvd to /dev/hdd. Actually, you can even do it if it is a combo drive - I do it. First remove /dev/dvd and then:
ln -s /dev/hdd /dev/dvd

This will link /dev/dvd to /dev/hdd and you can enable dma for your dvd drive by enabling it for /dev/hdd (is this what you want to do?).

babysealclubber 11-01-2003 12:47 AM

You guys are fast to reply... anyway, I figured it out in a roundabout way. I ran k3b as root and looked at what devices it probed for writer and reader devices (they're completely seperate physical drives, yes) and it found my CDRW, which was /dev/scd0, like I thought, and the DVD was /dev/hdd. Only thing now is how to give k3b full access to the devices so I can run it as a user... I bet that's a good search topic.

I was going to try just mounting /dev/hdd the first time, but that would have been too obvious so I never tried it...

That's almost as bad as when someone asked me how to check mail in local mailboxes:

"mail, duh"

Don't I feel retarded.

Thanks guys. Just goes to show that even if you can't help someone, you make them frustrated enough to look harder and find what they're looking for.


mshumer 12-19-2008 12:55 AM

I am running Ubuntu 8.04.1 on acer aspire one and am having the same problems. Couldn't get acidrip or mplayer to run DVD. /dev/dvd didn't exist. I looked at properties of the DVD that popped up on desktop when I plugged in usb. Found it at /media/cdrom0 plugged that into acidrip and everything worked peachy!

All times are GMT -5. The time now is 07:57 PM.