LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Dell Precision 670 Integrated NIC REFUSES to work with linux (https://www.linuxquestions.org/questions/linux-hardware-18/dell-precision-670-integrated-nic-refuses-to-work-with-linux-339168/)

silex_88 07-01-2005 04:34 PM

Dell Precision 670 Integrated NIC REFUSES to work with linux
 
The POS works fine with windows XP 64-bit.

When I install fedora (I've tried both i386 and x86_64), while the kernel loads it displays the Bringing up interface eth0: [OK].

When X is booted, the device appears as active, and is detected as Intel Corporation 82545GM Gigabit Ethernet Controller.

All the IP/gateway information is correct and double-checked (same as under windows where it works fine).

e1000 driver appears when I do lsmod.

Tried SUSE; doesn't work either.

Suggestions? I know Dell is utter shit buy I'm stuck with it.

The next step is to contact dell tech support, please don't let it come to that!

Half_Elf 07-03-2005 07:48 PM

Ok, so I take that your network card have a valid ip and that the routing is correct, right?
What's happen when you try to ping/reach a website then? What kind of error message do you get?
consider posting the output of :
lspci
ifconfig
route -n
cat /etc/resolv.conf

silex_88 07-05-2005 01:39 PM

little update on the situation, i was \tying to further diagnose the problem (tried pinging the gateway ip, didn't work) when the computer hanged, so i restart it and it takes a while to load. so it chugs along, booting at about 1/4 speed, and when gnome is loaded its also really unresponsive. i open a terminal, and lo and behold instead of [X@localhost ~] it gave me a name (X@blahblah) and I can ping the gateway and the internet is suddenly working.

BUT its still really unresponsive. completely flabbergasted it suddenly worked (I didn't change any settings before it crashed) I try rebooting again to see if it still works. It doesn't, instead it boots full speed and I can no longer ping gateway or any external ip.

when i ping anything it simply returns a "host not found" error.

has anyone else experienced something similar?

hi half_elf,

relevant output from lspci:

03:0e.0 Ethernet controller: Intel Corporation 82454GM Gigabit Ethernet Controller (rev 04)

ifconfig:
eth0:
Link encap:Ethernet HWaddr 00:12:3F:46:65:8D
inet addr:129.6.104.159
inet6 addr:fe80::212:3fff:fe46:658d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1442 errors:3875 dropped:7750 overruns:3875 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes: 145038 (141.6 KiB) TX bytes:0 (0.0 b)
Base address:0xdcc0 Memory:dfee0000-dff000000
lo:
Link encap:Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2114 errors:0 dropped:0 overruns:0 frame:0
TX packets:2114 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2365366 (2.2 MiB) TX bytes:2365366 (2.2 MiB)

route -n:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
129.6.104.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 129.6.104.254 0.0.0.0 UG 0 0 0 eth0

silex_88 07-05-2005 04:58 PM

half_elf you still out there? :P

Half_Elf 07-05-2005 05:35 PM

well yes, but I am lost... obliviously, there is something terribly wrong about your card or the driver but I can't really tell you what. Do you see something odd or unusual if you type "dmesg" ?

silex_88 07-06-2005 11:12 AM

K there a few warnings and errors in the output of dmesg:

shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp:acpi_shpchprm:get_device PCI ROOT HID fail=0x5

...repeated like 5 times, not sure what they mean.

then there is:

e1000: eth0: e1000_watchdog_tak: NIC Link is Up 100 Mbps Full Duplex
NETDEV WATCHDOG: eth0: transmit timed out
eth0: no IPv6 routers present

where the first 2 lines appear again several times

Half_Elf 07-06-2005 11:24 AM

ok, something wrong about the PCI bus... My guess would be to try to add "pci=noacpi" to boot option (edit the "append=" line in lilo.conf then type "lilo"... I don't know grub much but it should be about the same), maybe your acpi implementation is buggy about pci.

silex_88 07-06-2005 11:54 AM

Hmm, it didn't seem to help. I make sure I pass the pci=noacpi option when I boot the kernel from grub but the acpi daemon still runs (not sure if this is normal) and I still can't ping the gateway.

Unless you have any other suggestions I'm going to try another distribution (which probably won't help, but is probably worth a try).

Oh and thanks for the help!

Half_Elf 07-06-2005 12:57 PM

I'm lost I don't have other suggestion right now, unless you want to learn to recompile your kernel (then yes I would have some suggestion :) )


All times are GMT -5. The time now is 03:32 PM.