-   Linux - Hardware (
-   -   Dell Latitude C640 won't connect to any wireless network (

beezum88 07-04-2011 11:42 AM

Dell Latitude C640 won't connect to any wireless network
So my dad has an old Dell Latitude C640 that we're trying to install linux on. We've tried three different versions of Ubuntu (Karmic, Lucid, and Natty) as well as openSUSE 11.2 and all of them have the same problem. The network manager sees wireless networks but won't connect to them, and it doesn't matter what kind of wireless security is on the network. It just sits there trying to connect forever.

We also followed the instructions in this thread ( to manually connect using the terminal and it doesn't seem to have done anything from what we can tell.

Any ideas on what we can do?

Here's the output of lshw -C Network:

user@ComputerName:~$ sudo lshw -C Network
[sudo] password for user:
      description: Ethernet interface
      product: 3c905C-TX/TX-M [Tornado]
      vendor: 3Com Corporation
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: eth0
      version: 78
      serial: 00:0b:db:05:a8:5f
      size: 10Mbit/s
      capacity: 100Mbit/s
      width: 32 bits
      clock: 33MHz
      capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
      configuration: autonegotiation=on broadcast=yes driver=3c59x duplex=half latency=32 link=no maxlatency=10 mingnt=10 multicast=yes port=MII speed=10Mbit/s
      resources: irq:11 ioport:ec80(size=128) memory:f8fffc00-f8fffc7f memory:f9000000-f901ffff
      description: Wireless interface
      physical id: 2
      logical name: eth1
      serial: 00:02:2d:70:28:fe
      capabilities: ethernet physical wireless
      configuration: broadcast=yes driver=orinoco_cs driverversion=2.6.38-8-generic firmware=Lucent/Agere 9.48 link=yes multicast=yes wireless=IEEE 802.11b

TobiSGD 07-04-2011 11:47 AM

Please post the output of

This should show us which chipset that laptop uses for wireless.

beezum88 07-04-2011 03:59 PM

Here you go. I'm not sure I see a wireless card in this list, though.


00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:01.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
02:01.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
02:03.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)

TobiSGD 07-04-2011 04:06 PM

May it be that you have an USB wireless adapter? In that case post the output of

Check also if it may be possible that the wireless is disabled, most laptops have a switch for that.

beezum88 07-04-2011 05:02 PM

I don't think lsusb will help, but here it is:

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
I also don't think it's a hardware enable/disable switch. If the card were completely disabled, I don't think wireless networks would even show up in the list. Instead, I can see all the available networks, and choose one to attempt to connect to. It just never finishes trying to connect. Also, in the network manager menu, "Enable Wireless" is checked.

frankbell 07-04-2011 09:09 PM

According to the specs (PDF), it came with Dell-branded wireless card, but, I was unable to track down in the time I was willing to devote to it who manufactured the card for Dell.

beezum88 07-05-2011 03:41 PM

Thanks, I tried the wifi again using the latest Damn Small Linux and an old Mandriva disk we had lying around. DSL couldn't find a wifi card at all, but Mandriva seems to have exactly the same problem as Ubuntu and openSUSE. However, it identified the card as "Dell TrueMobile 1150 Series PC card version 01.01". I looked this up on Google, though, and it looks like a card that you need to stick in a PC card slot, not something that would be built in to the laptop.

I then opened the wifi card cover on the laptop (don't know why I didn't do this sooner) and copied down everything that was on there. There's what looks like a serial number (got nothing when I put it in Google), and then it says "mpci3a-20/r Agere Systems". That is apparently the actual card installed in the laptop.

I also found <a href="">this thread</a> googling for the Dell TrueMobile card. after reading through it, I ran lspcmcia and got the following:

Socket 0 Bridge:          [yenta_cardbus]        (bus ID: 0000:02:01.0)
Socket 1 Bridge:          [yenta_cardbus]        (bus ID: 0000:02:01.1)
Socket 2 Bridge:          [yenta_cardbus]        (bus ID: 0000:02:03.0)
Socket 2 Device 0:        [orinoco_cs]                (bus ID: 2.0)

"orinoco_cs" is the driver listed for the "wireless interface" when I run lshw.

I also went ahead and ran the following:

eth1      IEEE 802.11b  ESSID:"NoSuchPlace" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 3C:EA:4F:30:FD:D9 
          Bit Rate:11 Mb/s  Sensitivity:1/0 
          Retry limit:8  RTS thr=2347 B  Fragment thr:off
          Power Management:off
          Link Quality=51/70  Signal level=-51 dBm  Noise level=-92 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:5
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

lsmod | grep orinoco:
orinoco_cs            12898  1
orinoco                69899  1 orinoco_cs
cfg80211              156212  1 orinoco
pcmcia                39671  1 orinoco_cs
pcmcia_core            21505  4 orinoco_cs,pcmcia,yenta_socket,pcmcia_rsrc

dmesg | grep orinoco:
[  27.087980] orinoco 0.15 (David Gibson <>, Pavel Roskin <>, et al)
[  27.178695] orinoco_cs 2.0: Hardware identity 0005:0004:0005:0000
[  27.178817] orinoco_cs 2.0: Station identity  001f:0001:0008:000a
[  27.178823] orinoco_cs 2.0: Firmware determined as Lucent/Agere 8.10
[  27.575933] orinoco_cs 2.0: Hardware identity 0005:0004:0005:0000
[  27.576071] orinoco_cs 2.0: Station identity  001f:0002:0009:0030
[  27.576077] orinoco_cs 2.0: Firmware determined as Lucent/Agere 9.48
[  27.576082] orinoco_cs 2.0: Ad-hoc demo mode supported
[  27.576085] orinoco_cs 2.0: IEEE standard IBSS ad-hoc mode supported
[  27.576089] orinoco_cs 2.0: WEP supported, 104-bit key
[  27.576093] orinoco_cs 2.0: WPA-PSK supported

dmesg | grep eth1:
[  27.647359] ADDRCONF(NETDEV_UP): eth1: link is not ready
[  63.026279] eth1: Lucent/Agere firmware doesn't support manual roaming
[  63.241780] eth1: New link status: Connected (0001)
[  63.241849] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  64.568330] eth1: Information frame lost.
[  64.576310] eth1: Information frame lost.
[  64.715203] eth1: Information frame lost.
[  64.723053] eth1: Information frame lost.
[  64.966064] eth1: Information frame lost.
[  64.976354] eth1: Information frame lost.
[  65.216919] eth1: Information frame lost.
[  65.416802] eth1: Information frame lost.
[  65.417215] eth1: Information frame lost.
[  65.817714] eth1: Information frame lost.
[  66.264719] eth1: New link status: Disconnected (0002)
[  67.523536] eth1: New link status: Connected (0001)
[  70.547720] eth1: New link status: Disconnected (0002)
[  71.575815] eth1: Information frame lost.
[  71.583302] eth1: Information frame lost.
[  71.593574] eth1: Information frame lost.
[  71.600737] eth1: Information frame lost.

The eth1 output continues in a similar fashion for several hundred more lines. I have chopped it short for brevity.

Anyway, if any of this gives someone an idea on how to approach the problem from here, let me know. Otherwise, There are two expansion slots (PCMCIA, I think) on the laptop. Any suggestions for a linux-compatible wireless NIC that I can stick in one of the slots?

frankbell 07-05-2011 08:16 PM

(Edit) It almost sounds as if this PCMCIA card may be too old for Linux kernel wireless support. I don't know this for a fact, but the funky way it responds to various detection test leads me in that direction.(End Edit)

If you can find a Windows driver for the card, maybe on the Dell site, ndiswrapper might work. When it works, it's rock solid. When it doesn't, it doesn't. I've had it work for me on Slackware 10.x, then fail on Slackware 12.x, both times with the same PCMCIA card in the same computer.

If you know anyone who has a USB wireless card, it would be worth a shot to borrow it see if it can be made to work. If so, a new USB card might be the best way to go.

frankbell 07-06-2011 10:44 PM

We were talking about this tonight at our pre-LUG meeting dinner.

Some of the older members (not older in years, older in Linux) remembered situations such as this, in which Linux saw the card and could not communicate with it, from the PCMCIA card days. "Acera" (or something like that) was a brand that one of them remembered.

They suggested trying a different make PCMCIA card, if you can dig one up somewhere.

If you have a reputable independent second-hand store nearby, that might be a place to look if you want to pursue this. The one I used for years before I moved back home to Virginia used to sell grab-bag used stuff for five dollars (with no guarantee, of course).

beezum88 07-29-2011 11:50 PM

Thought I'd tie up some loose ends on this thread. Dad decided it wasn't worth the trouble and just stuck WinXP back on the laptop, which works fine. I could probably have installed the Windows driver (which works like a champ) with ndiswrapper, but oh well.

frankbell 07-30-2011 08:31 PM

Thanks for the update.

Wireless was the Achilles heel of Linux for a long time.

penguintutor 01-20-2012 03:57 PM

Install drivers using firmware-b43-installer
I realise that this thread is now over 6 months old, but this may help if anyone has this problem in future:

The C640 didn't come with Wireless as standard, but has a slot for a mini-wireless card. The card typically used is a Dell branded card, but is based on the broadcom chipset.

In earlier versions of Ubuntu this was installed as long when installing system updates as long as the laptop was connected to the Internet at the time (ie by ethernet cable).

This does not seam to happen with 11.10

To run this manually connect to the internet via cable and run

sudo apt-get install firmware-b43-installer

This will download the firmware from the Internet and install the appropriate driver. You should then be able to select the appropriate network from the normal network list.

penguintutor 01-21-2012 04:44 AM

Oh - and one more thing ...

If you have the broadcom-sta-common package installed it blacklists the b43 driver which is required for wireless.

To fix - edit the file /etc/modprobe.d/broadcom-sta-common.conf
delete (or comment out with a #) the line

blacklist b43
Then to force the module to load edit /etc/modules
add a line with


- It should now still work after a reboot.

Finally as I said earlier this is if you have a Broadcom mini-wireless card. As the card was not included by default it may be that a different card was put in.

To check what card is installed use the command:


$lspci | grep Network
Which will show what wireless card is installed:

02:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

StinkyB 04-29-2014 11:17 AM

C640-Ubuntu-Wireless SUCCESS!!
Hello, Everyone - This is my first post in this forum, and I feel compelled to reply as I would not have been able to get this resolved without the prior work of everyone else in this thread - thank you, all - beezum88, TobiSGD, frankbell, penguintutor.

As it turns out, you guys were oh-so-close... and to be honest, this is not rock-solid yet. But, I knew I was getting somewhere when I was able to get the laptop talking to the router. Figuring out the issues w/DNS was a whole other story, but I finally cross-ref'd enough forums and got the laptop talking to the external network. You have no idea how happy I was when Firefox finally showed the Google home page!

Basically, I was able to get this working through a combination of:

1) Installing the NDISWrapper pkg
2) (Temporarily) disabling the router security (wanted to eliminate WEP/WPA resolution as an issue)
2) Manually configuring the wireless interface in /etc/network/interfaces
3) Adding in the appropriate DNS entries (in /etc/network/interfaces as well).

I still need to scale up this solution w/wifi security enabled as well as DHCP, but knowing that this specific wifi card, can be made to work is awesome!!


StinkyB 04-29-2014 01:16 PM

Update on C640-Ubuntu-Wifi Success...
Now working with DHCP instead of static TCP/IP config in /etc/network/interfaces:

Changed eth0 entry


iface eth0 inet static
dns-nameservers (my isp's DNS servers)
dns-search local


iface eth0 inet dhcp

Now, on to WEP/WPA...


All times are GMT -5. The time now is 12:42 AM.