-   Linux - Hardware (
-   -   Dell BIOS won't find IDE HD - LiveCD will. (

Arla 05-29-2007 12:59 PM

Dell BIOS won't find IDE HD - LiveCD will. ("solved")
I'm sorry, this is not really Linux. But I figured you guys would know the answer anyway.

The desktop machine, as well as its BIOS, is from Dell. It came with a SATA hd which I've been using for Winxp for a year, but now I have inserted an old IDE, to use for Linux.

The problem is that it won't appear in the list of HDs in the BIOS menu, but will be accessible from a Gentoo LiveCD.

Could it be a jumper problem? Shouldn't it at least appear whatever the jumper setting is? There is btw also an IDE disc drive (which is found by BIOS).

Other threads suggest that the BIOS is to old and the drive too large, but seeing how the computer is only one year old, I can ignore that one, can't I.

pljvaldez 05-29-2007 02:37 PM

Make sure the IDE hard drive is the master and the IDE CD drive is the slave. I had this problem recently where the bios refused to identify a hard drive if it was the slave to a CD drive. Reversing the order they were plugged in on the ribbon cable fixed the problem.

Junior Hacker 05-29-2007 04:12 PM

Jumper settings do matter, if both the optical drive and the hard drive are on the same channel (same ribbon cable), put the optical drive on the center connector and the hard drive on the end connector and set the jumpers to CS (cable select) on both drives. It is also possible that because all that was meant to go on the IDE channel was optical drives, DELL may have only included a 40 wire ribbon instead of an 80 wire which is recommended for modern IDE hard drives, check to see which one is included, this however, should not cause the bios not to see it.

Arla 05-30-2007 05:33 AM

BIOS doesn't like slaves.
Okay, this is strange. The conclusion I have drawn from the following is that BIOS doesn't like slaves :/

(hd=hard drive, od=optical drive)

With the jumpers on the od AND on the hd set to CS, I got the hd to MA when connecting it to the MA connector, but nothing on SL (although I, of course, connected the od to the SL connector). Switching their places, I got the od on MA and still nothing on SL.

Setting the hd jumpers to MA and the od jumpers to SL, then, gave me the hd as MA and nothing on SL, for both cable orders.

rupertwh 05-30-2007 07:24 AM

Um, maybe the slave is simply disabled in the BIOS?

Junior Hacker 05-30-2007 02:49 PM

Or a bad ribbon cable. Borrow one from another computer temporary.

Arla 05-30-2007 04:32 PM


Originally Posted by Junior Hacker
Or a bad ribbon cable. Borrow one from another computer temporary.

Tried with that one. Same result.

And no, it's not disabled. It doesn't even appear.

Junior Hacker 05-30-2007 04:45 PM

If that's the case, it's starting to sound like a software controller failure, which is part of the main chip set on the mother board. Meaning the chip set is hooped. Or some tracing got scratched or overheated on the mother board cutting off that connector. As far as the bios not reporting the information correctly, is a long shot, I would peg the chip set first. You can however, visit the computer manufacturer's web site or the mother board manufacturer's site (check computer vendor first), and see if there is a bios update available, most computers had one shortly after they were produced, they can usually tell you how to find what version is installed on the computer, and if the numbers are higher for the update, you might as well install (flash) it. Even if you have the latest, it might be worth flashing it again.

Arla 05-31-2007 08:00 PM

I don't know what happened, but now they are detected as expected. I have booted from CD and from the IDE HD a couple of times, and now in BIOS both of them are visible.

So there was never a problem booting from them. I just got confused over how the BIOS acted. Thank you guys for trying to help!

All times are GMT -5. The time now is 01:01 AM.