-   Linux - Hardware (
-   -   Dell 1390 WLAN Minicard does not configure with FC7 (

mmsprinter 12-20-2007 07:21 PM

Dell 1390 WLAN Minicard does not configure with FC7
I just installed FC7 on a Dell Inspiron E1505. It has a Dell 1390 WLAN Mini card in it.
I can't seem to get the wireless card to work. I read on another forum to get NDISwrapper, and the Windows driver. But NDISwrapper won't install. I followed the instructions on the website but I get an error with the first command I run, "make distclean". This is the output I get:

make -C driver clean
make[1]: Entering directory `/root/Desktop/ndiswrapper-1.51/driver`
Makefile:24: *** Kernel tree not found - please set KBUILD to configured kernel.
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.51/driver`
make : *** [clean] Error 2

I'm new at any flavor of linux, so I don't what any of this means, except that there was an error. A friend of mine said it might be a missing kernel file.

Help. Thanks

Brian1 12-20-2007 08:46 PM

you are installing the source file. Under Fedora distros you need to install the kernel source before building utility like ndiswrapper. It builds modules that must be built per kernel version. If you have done no updates then you can install the kernel-devel-********.rpm off the cd. must be done as root.
rpm -ivh kernel-devel*.rpm

Now you should be able to compile ndiswrapper.

Other way is use yum to install. Many post on this procedure. Using yum you install ndiswrapper rpm and the kmod-ndiswrapper rpm that matches the kernel you are using.

Note if you upgrade the kernel you must do again what you did to get ndiswrapper to work on the new kernel.


mmsprinter 12-21-2007 06:12 PM

I already ran updates, the 300 and some. But I decided to try it anyway.

I got the disc and installed kernel-devel-2.6.21-1.3194.fc7.i586.rpm. I went to try to install/compile ndiswrapper, and no go. So I installed the other rpm, kernel-devel-2.6.21-1.3194.fc7.i686.rpm.It said it was already installed.

Do I need to install a fresh copy of Fedora? It's no problem if I do.

Brian1 12-21-2007 07:41 PM

Post output from the following commands
uname -r
rpm -qa | grep kernel


mmsprinter 12-21-2007 09:52 PM

The output for uname -r was:

And the output for rpm -qa | grep kernel was:

Brian1 12-23-2007 09:27 AM

As you can see you are running kernel But you do not have the matching kernel source which is called kernel-devel- You do have kernel-devel-2.6.21-1.3194.fc7 but it is a completely different kernel-devel file. So you need to install the matching kernel-devel rpm for the running kernel. Then you will be able to compile ndiswrapper from source. Remember if you upgrade the kernel then you need to install the matching kernel-devel for the new kernel and re-compile the ndiswrapper for that kernel.


mmsprinter 12-23-2007 11:45 AM

Ok I get it. Thanks Brian. I'm new at linux so I'm slowly learning something new every day. Thanks

mmsprinter 12-23-2007 01:37 PM

I totally reinstalled Fedora and did not even touch the updates. When I try to installs I still get an error. I installed the same kernel devel as my kernel, 2.6.21-1.3194.fc7. I get past the first command, make distclean, and when I move onto, make install, this my output

make -C driver install
make[1]: Entering directory `/root/Desktop/ndiswrapper-1.51/driver'
make -C /usr/src/kernels/2.6.21-1.3194.fc7-i686 SUBDIRS=/root/Desktop/ndiswrapper-1.51/driver
/usr/src/kernels/2.6.21-1.3194.fc7-i686/scripts/ line 11: gcc: command not found
/usr/src/kernels/2.6.21-1.3194.fc7-i686/scripts/ line 12: gcc: command not found
make[2]: gcc: Command not found
make[2]: Entering directory `/usr/src/kernels/2.6.21-1.3194.fc7-i686'
CC [M] /root/Desktop/ndiswrapper-1.51/driver/crt.o
/bin/sh: gcc: command not found
make[3]: *** [/root/Desktop/ndiswrapper-1.51/driver/crt.o] Error 127
make[2]: *** [_module_/root/Desktop/ndiswrapper-1.51/driver] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.21-1.3194.fc7-i686'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.51/driver'
make: *** [install] Error 2

This might have something to do with it. In the instructions for install, it says run, make install, in the source-directory. I don't have a source directory, or is it the original directory?

Brian1 12-24-2007 01:10 PM

OK post the output again of the following.
uname -r
rpm -qa | grep kernel
rpm -qa | grep gcc

I have the feeling not everything is installed. I always do a full install and check everything. Make things like this easy if all rpm packages are installed.


mmsprinter 12-25-2007 12:38 AM

The output for uname -r:

for rpm -qa|grep kernel:

for rpm -qa|grep gcc:

Does the libgcc have to be the same as the kernel and kernel devel?
Should I do another install and select everything, instead of just Office and Productivity?

Brian1 12-25-2007 09:06 AM

you do not have gcc installed. Goto the install cd and look for gcc rpm. Use the command as root ' rpm -ivh gcc*.rpm '. Not sure but may require more dependency rpms. You will have to add all like so as an example.
rpm -ivh gcc*.rpm libgcc*.rpm pango*.rpm. This is only and example. I would use a more specific full name for each package so other files not needed are not installed.

If you setup yum to use the cd then you can use yum to do the install for you and find the needed rpms. Many post here on setting up a local repo for yum.

Last easiest to me would be re-install with everything.


mmsprinter 12-26-2007 08:33 PM

I totally reinstalled, with everything, and tried to install...error.
I ran uname -r and got: 2.6.20-2925.9.fc7xen

I ran rpm -qa|grep kernel:

Now I don't have any kernel devel. I looked on the disc, there is no devel that matches my kernel.

The output for rpm -qa|grep gcc:

Brian1 12-28-2007 06:32 PM

Where did the Xen kernel come from. If off the CD and no matching kernel-devel then no idea other than searching fedora mirror rpms for it. Unless you plan on some virtual OSing then I would not bother with the xen and boot with the other kernel kernel-2.6.21-1.3194.fc7. Then install the kernel-devel-2.6.21-1.3194.fc7.rpm from the CD.


mmsprinter 01-01-2008 06:35 PM

I got Ndiswrapper installed, and the driver according to the website. It shows that the driver is installed, and working. But the card still does not work. Do I have to do anything else?

mmsprinter 01-03-2008 03:48 PM

I switched to Ubuntu 7.10 and followed instructions off of and I got it working. Thanks for helping me through this ordeal.

All times are GMT -5. The time now is 09:56 AM.