LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Debian Woody r1 Installer won't detect SATA RAID HDDs on SiI 3122A (https://www.linuxquestions.org/questions/linux-hardware-18/debian-woody-r1-installer-wont-detect-sata-raid-hdds-on-sii-3122a-136234/)

bluPSU 01-19-2004 01:08 AM

Debian Woody r1 Installer won't detect SATA RAID HDDs on SiI 3122A
 
I am having trouble installing Debian Linux on my wonderful new computer. The problem is essentially that the Installer can't recognise any of my Seagate SATA hard Drives running off my Silicon Image 3112A SATA Controller. Does anyone have a suggestion for how I may solve this problem and get debian working. I noticed that the Installer asked for a module preload disk in a similar fashion to WinXP (what I am running as I am typing this) so if anyone would be so kind as to make a Module Preload disk for me i would be evermost grateful. Any other suggestions for how to get my computer working as a Personal Desktop (Running Debain 3.0 or greater) would also be greatly appreciated.

My hardware is as follows
  • Gigabyte GA-8I875 Ultra (Motherboard)
  • Pentium IV 2.8 GHz -C (800 MHz FSB)
  • 1 GB (2x 512 MB Sticks) GeiL DDR400 Dual Channel RAM
  • 160GB (2x 80 GB Drives) Seagate Barracuda SATA-150 Hard Disk Drives
  • Silicon Image SiI 3112A SATA RAID Controller
  • Intel 875P Chipset (ICH5-R as SouthBridge)
  • Intergrated Intel Gigabit Network Adapter
  • Intergrated AC'97 Audio with a 6 Channel UAJ + Jack Sensing
  • Power Color ATi Radeon 9600XT (128MB)
  • Integrated Firewire (IEEE 1394)
  • Integrated USB2
  • Integrated USB 1.1
  • LiteON 52x32x52 CD Burner
  • Floppy Drive


Also if anyone could suggest what drivers to use with my network card, graphics card and audio, and how to get the installer to handle them, that would be greatly appreciated.

Aussie 01-19-2004 01:23 AM

Probably the kernel in woody 3.0 is too old to include SiI SATA support (try saying that ten times really fast;-), you may need to make a custom boot disk with a newer kernel, 2.4.24 would seem to be the obvious choice, an other alternitive would be to give slackware 9.1 a whirl, it supports SiI SATA out of the box, so to speak.

hw-tph 01-19-2004 01:25 AM

Support for the Sil3112 controller is available only in 2.4.22 and later, if I remember correctly. The support is still pretty scetchy and performance is actually a lot worse on my NF7-Sr2 - 25MB/s at best - than on my old A7V whose Promise 20265 ATA100 controller gives me about 59MB/s throughput.

You could either try building a custom boot disk, or try some other solution. I opted to install using the Gentoo experimental (but the stable 1.4 stages) installer, which went fine. Performance is still very dissappointing, after having tried several different kernels and kernel configurations.


Håkan

bluPSU 01-19-2004 04:06 AM

Hello All...

Firstly, Worse than saying "SiI SATA Support" ten times fast is saying it once, really fast with a whole heap of other numbers (like ICH5-R & DDR400) to a Windows NetAdmin who probably would not understand what you said anyway.
Secondly, I am glad that you agree with me that the woody kernel is too old, even doing a bf24 install. I am not sure how to make a custom boot disk though, but would it be a better idea to use a newer version of debian like Sarge (testing) or Sid (Unstable). I guess the main thing that I like about Debian is Apt, however if Slackware is a better distro, I can live with it, hey I probably might like Slackware. I class myself as an advanced newbie which basically means that I am competent with the command line and VERY easy programming languages (I am learning perl at the moment) I probably could compile a Kernel but I have never tried it. The Impressions that I get from Slackware and Gentoo is that they are very nice distros but you basically have to install them yourself entirely off the command line, which seems very daunting, please correct me if i'm wrong.
Finally, Performance is not really an Issue for me, it would be nice, but this is sure to pickup and become far superior as time progresses.

In Summary
If anyone thinks that I could use a later version of the debian Installer, tell me so I can download it, I am happy to spend money if it will work, and that applies to Gentoo and Slackware too, if you think that They would work then I will perservere until i Like it (It's linix, what's not to like?) Also I am happy to use a custom boot disk, but if anyone will make one for me i would appreciate it (Preferably a sarge boot disk or even sid, whetever is best) or if you could direct me into how to make it.

Thank you for your help.

bluPSU
(The inspiration came from my Antec SmartBlue 350w PSU ironically)

Aussie 01-19-2004 05:13 AM

Get a copy of slackware 9.1, and update it as as you finish the install, a little app called Swaret will be a good slack sub for apt.

Quote:

swaret is a script to help keep your Slackware System up-to-date.

swaret Upgrades, Installs, Re-Installs, Downloads,...
Packages, Patches, Sources (with Build Scripts) and much more!
swaret includes Dependency Support, which Tracks and Fixes missing Libraries

bluPSU 01-19-2004 05:26 AM

Slackware 9.1 seems gr8, but how is the install, debian install is atrocious (better than my 1st disrtro, Lyoris) esp. can u get the installer 2 configure x11 so it works... My old machine with Nvidia GF3|ti could not be configured with x properly due to my limited knowledge, that is one reason for the Radeon this time round.

Thanks
Blu:)

Aussie 01-19-2004 05:46 AM

Slacks installer is better than Debians, and you just use "xf86config" to configure X, but not until after the install - and you need the binary drivers for both Nvida and ATi if you want hardware 3d acceleration - ATM Nvidia's linux driver is easier to install than ATI's is - but ATi is catching up, both drivers work well once installed.

bluPSU 01-20-2004 12:41 AM

Ok, this morning I downloaded Slackware 9.1 Disc1 & Disc2 and burend them to CDROM, then I booted of Disk1, with raid.s kernel...
The Computer detected /dev/md0 which consisted of /dev/hde1 and /dev/hdg1 because I have previously set tem with partitions of type fd or Linux Raid AutoDetect... In accordance with the "Setting Up software RAID" page that I found on the web at This Page and then I set up my partitions (i.e. /dev/md0p1 through /dev/md0p6) using fdisk and cfdisk. Afterwhich I typed setup and tried to Initialise a swap partition, it said that It coud not find a swap partition when it should have recognised /dev/md0p2 (yes a already set this partition up as type 82 or Linux Swap) and the only detectable hard drive was /dev/md0... I tried installing LILO onto the MBR and the thing spat the dummy and would not install LILO, ot then continued to finish the Installation. I rebooted and IT WOULD NOT BOOT! So i had to reinstall the Windows eXPerience so now i am stuck here. Any Ideas... Keep in mind that No RAID is not an Option...:cry:
Also what is the Linux drive numbering scheme (not things like /dev/hda1 etc... more like dev/md0p78 or /dev/rd/whatever) and are there any CLI tools on the Slackware 9.1 CD that can detect all drives.

Thankyou In advance
Blu:confused:

Aussie 01-20-2004 02:56 AM

Try using "cfdisk" just after you log on and before you do 'setup'

bluPSU 01-20-2004 06:23 AM

Aussie...
I am experienced using both fdisk and cfdisk and I have no trouble setting up the partitions, my dilemma is that the setup won't detect the Partitions... It detects /dev/md0 but not the partitions as listed by cfdisk being /dev/md0p1 /dev/md0p2 /dev/md0p3 and so on and so forth I believe that I HAVE initialised RAID witk mkraid /dev/md0 so any ideas as to why the setup program won't recognise my partitions?

Blu

P.S. Setup will recodnise the partitions as /dev/hde* and /devhdg*... incidentally /dev/hde1 and /dev/hdg1 make up the RAID array

Aussie 01-20-2004 06:45 AM

Aha, ic the problem now..'setup' is the problem.
You may need to install to an IDE drive them move it to the raid from the inside, so to speak.

bluPSU 01-20-2004 03:36 PM

Even if I do move to RAID from the inside... I do not entirely know how to get the partitioning scheme correct... What drives letters will the install detect... Is there a way to get it to probe more drives?

Thanks
Blu


All times are GMT -5. The time now is 04:03 PM.