-   Linux - Hardware (
-   -   debian problem with broadcom wireless card/driver (

mf93 06-26-2009 12:21 AM

debian problem with broadcom wireless card/driver
hi im new to Debian and linux in general. I am running kernel
2.6.26-2-amd64. and debian testing(squeeze) on my laptop has a broadcom wireless card so i decided to install the native drivers. So I read the manual and downloaded b43-fwcutter and the driver and installed the firmware. modprobe shows that the driver is installed, and when i run ifconfig -a i get this...

Interrupt:251 Base address:0x2000

lo        Link encap:Local Loopback
          LOOPBACK ...

wlan0      Link encap:Ethernet HWaddr ...

wmaster0  Link encap:UNSPEC HWaddr...

sry about not including everything but since i cant copy and paste(the debian laptop has no internet its not easy to type out chunks of code, so i included everything i thought is relevant, if u need more just tell me

but when i open /etc/network/interfaces all it shows in the file is:


myComp# vi /etc/network/interfaces

# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
# /usr/share/doc/ifdown/examples for more information.

nothing in the file about any of my devices.

Also, when i run lspci it fills the screen with devices but heres what it says about network devices:


09:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
0a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E P

This is weird because my wireless device is definitely broadcom and not Atheros but i think debian installed Atheros by default when it installed on my laptop. ty you so much in advance for your help!
and btw plz dont tell me to switch to ubuntu because i looked at all the different flavors and did my read opinions and asked friends and found Debian the best(for me at least)

jsteel 06-26-2009 06:01 AM

I think Debian is better too ;)

Don't worry about what is shown in /etc/network/interfaces, that file (mainly) stores any manual configurations that you have made. When you click the network manager icon in the panel is there any reference to any wireless devices or networks?

What's the output of "iwlist wlan0 scan"? If it says that the network is down (or similar) try running "ifconfig wlan0 up" and try again. Same problem? Try giving it an IP address with "ifconfig wlan0" and try again.

farslayer 06-26-2009 09:14 AM

I would believe the output of lspci.. it looks like you have an atheros ar2425/ar5007 Wireless chip, not a broadcom chip.

I have that wireless chip working perfectly in Debian using the openHal driver from the madwifi-project.

Heres the info I followed to get the wireless on my Acer Aspire One netbook working..

lspci -vv should show what driver module is being used for that pci device.

A little more info on your system would have helped verify the hardware as well..

mf93 06-26-2009 11:42 AM

ty both for your replies. here are more hardware specs for my laptop
none of the iwlist or ifconfig commands worked because the network really is down on that computer. Farslayer im going to trust you that my card is atheros i originally thought that it was broadcom because the vista driver was broadcom. Also lspci -vv scrolled a lot of the information off the page and i dont no how to unscroll it. Farslayer i am going to try your driver to see if that fixes it.

mf93 06-26-2009 06:27 PM

farslayer i installed the madwifi driver and now everything is working beautifully

farslayer 06-26-2009 10:44 PM

Huzzah !! Glad to hear things are working !!

I understand the gnome-network-manager does not function altogether properly with the driver you just installed. so if you want a alternate Graphical network manager I would recommend wicd I believe it's in the Debian backports repository if you decide to give it a try..

But if everything is working OK for you then, why fix it if it ain't broken :)

wabbalee 06-27-2009 12:18 AM


and btw plz dont tell me to switch to ubuntu
switch to Ubuntu.

mf93 10-04-2009 06:08 PM

a note to others using this as a guide---make sure the ath5k module is blacklisted otherwise madwifi will not work properly

All times are GMT -5. The time now is 10:27 PM.