LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-26-2006, 09:36 PM   #1
Chris107
LQ Newbie
 
Registered: Nov 2005
Posts: 6

Rep: Reputation: 0
Debian fails to detect onboard ethernet


I'm currently using a K8N Neo4 motherboard and I'm trying to install Debian. However once it tries to detect a network it fails to detect my onboard ethernet. Is there any solution to this? My friend suggests to just buy another network card.
 
Old 03-26-2006, 09:53 PM   #2
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
hi,
post the o/p of

#lspci

regards
 
Old 03-26-2006, 10:06 PM   #3
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Need to know what kind of onboard ethernet, what chipset?
 
Old 03-26-2006, 10:45 PM   #4
Chris107
LQ Newbie
 
Registered: Nov 2005
Posts: 6

Original Poster
Rep: Reputation: 0
It's an nForce4 chipset. I'd post a link but I need atleast 5 posts.
 
Old 03-26-2006, 10:45 PM   #5
Chris107
LQ Newbie
 
Registered: Nov 2005
Posts: 6

Original Poster
Rep: Reputation: 0
http://www.msicomputer.com/product/p...eo4-F&class=mb

There you go, sorry for the double post.
 
Old 03-26-2006, 11:54 PM   #6
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Has it got two ethernet ports or just the one? I have an nforce4 chipset with the nforce ethernet and a marvell gigabit ethernet and the marvell has crappy linux drivers, works for some not for others. I just use the nvidia one and it works great, that links specifically lists a marvell ethernet adapter, so is the marvell the only one or..?

You can get updated drivers off the manufacturers site for the marvell adapter, might be worth a shot.

http://www.marvell.com/drivers/search.do
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get Onboard LAN card to detect Irridium Linux - Hardware 7 06-20-2007 01:46 AM
Unable to detect onboard LAN on i915 board with RHL9.0 asowani Red Hat 4 12-06-2005 11:47 PM
Help, linux install didnt detect my onboard nic!! abefroman Linux - Hardware 4 11-18-2005 08:07 PM
alsaconf doesn't detect my onboard soundcard ByteWarrior Slackware 3 04-06-2004 09:36 AM
How to detect my onboard LAN adapter? Janus Linux - General 1 08-15-2002 07:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration