LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Debian ATI Radeon 9600 Problem (https://www.linuxquestions.org/questions/linux-hardware-18/debian-ati-radeon-9600-problem-159621/)

exark237 03-18-2004 08:27 PM

Debian ATI Radeon 9600 Problem
 
After downlaoding the new drivers from the ATI website, I aliened the rpm and installed. I used a dpkg-divert instead of a force so that I didnt have to mess up the libmesa package. Next I cded to /lib/modules/fglrx/build_mod and ran make.sh. Then cd .. and ran make_install.sh. I am not getting 3d accel. I beleive I have pinpointed the problem to the mdoule agpgart. I am running kernel 2.6.3 and so whatever agpgart accompanies that. I have agp compiled as a module and modprobed on boot. However, it does not give any output when modprobed besides who the interface was written by. In my 2.4.18-bf24 kernel, it gave me

Code:

agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected SiS 730 chipset
agpgart: AGP aperture is 64M @ 0xbc000000
[drm] AGP 0.99 on SiS @ 0xbc000000 64MB
[drm] Initialized radeon 1.1.1 20010405 on minor 0

now, it just gives me

Code:

Linux agpgart interface v0.100 (c) Dave Jones
and the X Error file tells me

Code:

(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe09f5000
(II) fglrx(0): [drm] mapped SAREA 0xe09f5000 to 0x4022e000
(II) fglrx(0): [drm] framebuffer handle = 0xe0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):    Name: fglrx
(II) fglrx(0):    Version: 3.7.6
(II) fglrx(0):    Date: Mar  5 2004
(II) fglrx(0):    Desc: ATI Fire GL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):    Build-Kernel UTS_RELEASE:        2.6.3
(II) fglrx(0):    Build-Kernel MODVERSIONS:        no
(II) fglrx(0):    Build-Kernel __SMP__:            no
(II) fglrx(0):    Build-Kernel PAGE_SIZE:          0x1000
(II) fglrx(0): [drm] register handle = 0xba800000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe09f5000 at 0x4022e000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)            *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xe0000000 FBMappedSize: 0x08000000
(II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(II) fglrx(0): Using hardware cursor (scanline 768)
(II) fglrx(0): Largest offscreen area available: 1024 x 7419
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        Solid Horizontal and Vertical Lines
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                32 256x256 slots
                16 512x512 slots
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled

If you want My XF86Config-4 I can post it.

If you could help it would be greatly appreciated

Pwnz3r 03-18-2004 09:01 PM

My friend Kody seemed to have the same problem but he ended up getting it worked out somehow. I'll direct him to your post the next time I talk to him and maybe he can be of use. All I know is that the NVIDIA drivers have no problems and are easy to get going.

ni3ls 04-12-2004 02:21 AM

ATI Radeon 9600 on Dell
 
After many hours fight I finally found that the driver found here: http://xoomer.virgilio.it/flavio.sta...installer.html

Combined with the following XF86Config-4 file worked for my Dell Inspiron 8600 with ATI Radeon 9600 Pro Mobile 128MB and my 1920x1200 monitor:

# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"
Load "dbe" # Double buffer extension

SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "type1"
Load "freetype"

Load "glx" # libglx.a
Load "dri" # libdri.a

EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

# ModulePath "/usr/X11R6/lib/modules"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

Section "InputDevice"
Identifier "Keyboard0"
Driver "Keyboard"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection


Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection



# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
Identifier "Monitor0"
DisplaySize 330 210
Option "DPMS"

HorizSync 31.5 - 110.0
VertRefresh 28 - 90

Modeline "1920x1200" 161.750000 1920 2020 2052 2184 1200 1202 1208 1235 -HSync -VSync
EndSection


# === ATI device section ===

Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"

# ### generic DRI settings ###
# === disable PnP Monitor ===
Option "NoDDC"
Option "NoDDC1"
Option "NoDDC2"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000100"
Option "MonitorLayout" "LVDS, AUTO"
Option "IgnoreEDID" "false"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "on"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "Yes"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "no"
Option "ForceGenericCPU" "no"
Option "KernelModuleParm" "agplock=0" # AGP locked user pages: disabled
BusID "PCI:1:0:0" # vendor=1002, device=4e50
Screen 0
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24

Subsection "Display"
Depth 24
Virtual 1920 1200
ViewPort 0 0 # initial origin if mode is smaller than desktop
EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

Section "ServerLayout"
Identifier "Server Layout"
Screen "Screen0"
InputDevice "Mouse0" "PS/2 Mouse -> Touchpad"
InputDevice "Mouse1" "USB Mouse"
InputDevice "Keyboard0" "CoreKeyboard"

Option "Xinerama" "off"
EndSection

#**********************************************************************
# DRI Section
# **********************************************************************
Section "dri"
Mode 0666
EndSection


### EOF ###

Just to help anyone else with same problems.

exark237 04-12-2004 05:10 PM

ni3ls, could you please give a detailed explanation as how to install the drivers you used. I tried to use the same drivers, but I failed miserably

PsychowanKenobi 03-30-2006 11:36 AM

Hi
I've been having the same problems with my ATI Radeon 9600 Pro (on a Gentoo box) and after having checked this thread, IT WORKS !!!

The magic answer is in the /etc/X11/xorg.conf file at this line :
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr

in my file it was at "on" by default, and now that i've switched it off it works fine
:p


All times are GMT -5. The time now is 11:44 AM.