LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   DDS4 Tape Drive not recognized (https://www.linuxquestions.org/questions/linux-hardware-18/dds4-tape-drive-not-recognized-596810/)

manojkb 11-03-2007 07:00 AM

DDS4 Tape Drive not recognized
 
I have a Dell GX620 machine with SLES9 64Bit version installed. Today I have added AEC6712UW SCSI card connecting to a DDS4 Tape Drive. The lspci command displays:

0000:04:00.0 SCSI storage controller: Artop Electronic Corp AEC6712UW SCSI (rev 01).

In the Hardware info, under storage media I can see AEC6712UW SCSI in the list. But I tried many combination of "mt -f /dev/st0 status" replacing st0 with st1 to st9, nst0 to nst9, oosst, nosst. But no luck. Can anyone tell me what would be the problem. And how can I solve it.
Thanks.

michaelk 11-03-2007 05:00 PM

A quick google does not provide much information but it looks like this SCSI controller uses the atp870u module. I do not know if this controller is still supported or how well it works with linux. You can see if the module is loading via the lsmod command. If not you can try:
modprobe atp870u.

manojkb 11-04-2007 12:47 AM

Thanks Michael, You are right. It is using atp870u module and I can see it in the driver section under Storage media of the Hardware info. In case if it is not a supported SCSI card which one you would suggest.

michaelk 11-04-2007 01:12 AM

So are you confirming the atp8780u module is loaded?

What about these modules
scsi_mod
st
sd_mod
sr_mod

Adaptec SCSI controllers are well supported.

manojkb 11-04-2007 02:14 AM

(What about these modules
scsi_mod
st
sd_mod
sr_mod)

I don't know how to use these modules. But the system says (as per Hardware information) it is using atp870u (not 8780) module for AEC6712UW scsi card. Please help me.

michaelk 11-04-2007 08:00 PM

These are the SCSI subsystem modules. If these are not loading then your not going to be able to use the tape drive.
The output of the console command lsmod should show all loaded modules.

manojkb 11-05-2007 04:18 AM

I ran the lsmod command and found all the modules you mentioned. The result is as under:

Module Size Used By
st 59428 0
atp870u 40484 0
sr_mod 34980 0
sd_mod 38400 12
scsi_mod 151808 6 sg,st,sr_mod,atp870u,libata,sd_mod

Can you figure out what is the problem. What should I do next.

michaelk 11-05-2007 07:53 AM

I'm not familar with this controller. Does it recognize the tape drive?

manojkb 11-06-2007 01:45 AM

The tape drive is not recognized at. I mean, I have used all names like st*, nst*, oosst*, nosst*. But nothing worked. so I think the drived is not recognized by the OS. Anyway, I am given up with this SCSI Card. I am planning to purchase a new one and try. Thanks for your inputs and advices Mr.Michael.

michaelk 11-06-2007 07:34 AM

I meant recognized by the controller not the OS. Make sure the tape drive has a unique device ID and that the last device is terminated correctly. Most controllers have a BIOS that scans for devices at boot up. The device ID and name will be displayed.


All times are GMT -5. The time now is 08:10 AM.