-   Linux - Hardware (
-   -   dark screen of despair (

nasenpinsel 09-05-2005 12:51 PM

dark screen of despair

I recently bought a Fujitsu/Siemens Lifebook E8020 with an integrated graphics card (Intel GMA 900) and a plug'n play monitor with a 1400x1050 resolution.

I tried to install various distros (SUSE, Mandriva, Linspire), which worked fine. But when I restart my system after the installation I only get until the x-server should be started. Then the screen gets dark (Suse) or the system jumps back to the command line (Mandriva).

I fiddled around with sax and fxdrake but basically got nowhere. I also loaded the vesa-thing but it didn't help.

After I have done a little research I guess that I either have to change the xorg-configurations (perhaps) or that I should try to load a linux driver for the Intel integrated card (maybe).

Either way, I am stuck, because I don't know if one of these steps could solve my problem and how I should do it.

I am a total newbie to the linux world.

Your help is greatly appreciated.

Cheers, Nasenpinsel

paulsm4 09-05-2005 03:41 PM

Assuming you're currently running suSE, try this:

1. Log on as "root"
<= If your main, GUI console is borked, you can log on to
other, "virtual" consoles by typing <Ctl-Alt-F1>, <Ctl-Alt-F2>, etc

2. Re-initialize your X config:
sax2 -a -r

3. Try restarting X
rcxdm start

4. Check your X server log for errors:
less /var/log/Xorg.0.log

'Hope that helps .. PSM

hitendra26 09-26-2005 02:03 PM

Hi Paul,

I am facing the same prob. I have Fujitsu/Siemens Lifebook E8020 with an integrated graphics card (Intel 915 GM) and a plug'n play monitor with a 1400x1050 resolution.

I ran the commands as suggested without any luck. Let me know what to look for in the log file. I am a newbie in the linux world.


nasenpinsel 09-26-2005 02:34 PM

Hi Hitendra,

I installed the preview of Suse 10 and the graphic stuff worked right out of the box. No additional configruation needed. Unfortunately, the wireless didn't work and so I switched to the preview of Unbuntu Breezy Badger and everyting runs without a glitch (graphics and wireless).

Cheers, Nasenpinsel

hitendra26 09-26-2005 06:08 PM

Thanks Nasenpinsel,

I could able to make it work after running 'sax2 -m 0=fbdev'


paulsm4 09-26-2005 06:48 PM

Which means that your video drivers probably crashed and died a horrible death on your particular h/w (whereas the vanilla, least-common-denominator driver "fbdev" was able to work).

All times are GMT -5. The time now is 02:28 PM.