LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-14-2004, 05:02 PM   #1
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Rep: Reputation: 15
CUPS printing, parallel port not found in lpinfo


Sorry if this been asked before-- I read most of the other threads on CUPS already and they haven't helped me.

I'm trying to set up my printer on my Slackware 9.1 system.
The Printer is a HP DeskJet 712C, and its connected to my parallel port.

When I type:

bash-2.05b# /usr/sbin/lpadmin -p DeskJet -E -v file:/dev/lp0 -m deskjet.ppd
lpadmin: add-printer (set device) failed: client-error-not-possible

when I type "lpinfo -v" here's what shows up.

network socket
network http
network ipp
network lpd
direct scsi
direct usb:/dev/usb/lp0
direct usb:/dev/usb/lp1
direct usb:/dev/usb/lp2
direct usb:/dev/usb/lp3
direct usb:/dev/usb/lp4
direct usb:/dev/usb/lp5
direct usb:/dev/usb/lp6
direct usb:/dev/usb/lp7
direct usb:/dev/usb/lp8
direct usb:/dev/usb/lp9
direct usb:/dev/usb/lp10
direct usb:/dev/usb/lp11
direct usb:/dev/usb/lp12
direct usb:/dev/usb/lp13
direct usb:/dev/usb/lp14
direct usb:/dev/usb/lp15

^^
notice that the parallel port does not show up.

i also type "modprobe parport_pc" and it says

bash-2.05b# modprobe parport_pc
FATAL: Module parport_pc already in kernel.

^^

I checked my .config file and my parallel port is indeed hard compiled into my kernel.

now when I type: "dmesg | grep parport"

parport0: PC-style at 0x378 [PCSPP,TRISTATE,EPP]
parport0: cpp_daisy: aa5500ff(98)
parport0: assign_addrs: aa5500ff(98)
parport0: faking semi-colon
parport0: Printer, HEWLETT-PACKARD DESKJET 710C
lp0: using parport0 (polling).

^ look what shows up!

I know I'm pretty close to getting this working. What am I missing?

thanks in advance for any help!
 
Old 05-16-2004, 04:11 AM   #2
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Is there anything else I need to add that would help?
 
Old 05-16-2004, 07:55 AM   #3
Rolf68
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
what does it show when you do:
ll /dev/lp0
Do you have the rights set properly and the device too?
 
Old 05-16-2004, 12:01 PM   #4
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
you mean

ls -l /dev/lp0?

when I do that, I get this:

sh-2.05b$ ls -l /dev/lp0
crw-rw---- 1 root lp 6, 0 Apr 27 1995 /dev/lp0

I looks like I get read/write access to lp0. I suppose that means I have the correct permissions.
 
Old 05-16-2004, 10:22 PM   #5
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
No takers? Has anyone had any sort of similar experience?

Is it just the way I'm typing it in the CLI?
 
Old 05-16-2004, 11:05 PM   #6
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
a shot in the dark but is cupsd running on your system?

also, have you tried using
localhost:631
in the location bar of a webbrowser? It will get you to the cups admin page.
 
Old 05-16-2004, 11:48 PM   #7
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
^^

Yeah I tried that first, actually. But there's not much output I can cut and paste when I do it through mozilla.

When I click the "add printers" button, I don't see a "lp0" option.
 
Old 05-17-2004, 04:37 PM   #8
Rolf68
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Ok... now we look if your lp0 is working properly....

- Attach your printer, turn it on and put paper in. Connect it firmly to comp.
- cat /etc/passwd > /dev/lp0
- cat /etc/passwd > /dev/lp0 (2-3 times until it starts printing)

If it prints it means your printerport is working then we can go on...
If not we must reconfigure your port.
 
Old 05-17-2004, 06:42 PM   #9
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
This is interesting..

Here's my output--

bash-2.05b# cat /etc/passwd > /dev/lp0
bash: /dev/lp0: No such device or address

Mystery!
 
Old 05-18-2004, 10:55 AM   #10
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
^^

how about I go about "enabling" lp0?

I thought my parallel port was enabled when I typed in dmesg and it showed up!

What's going on now?
 
Old 05-21-2004, 11:38 AM   #11
Frank_Drebin
Member
 
Registered: Feb 2004
Location: Atlanta, GA USA
Posts: 232

Rep: Reputation: 30
Just wanted to say thanks to ROLF68!

I had the exact same problem as the original poster with an HP Officejet T45xi. I ran all of the same commands as he did with the same results. After I changed the permissions on lp0 and restarted cups with /etc/rc.d/rc.cups restart it showed up.

Thanks Again Rolf68 and to everyone else here on the forum!
You guys are great!
 
Old 05-21-2004, 12:12 PM   #12
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Hey, well thanks for the update, too.

I'll try the same thing you did!

Linuxquestions makes me happy
 
Old 05-21-2004, 12:22 PM   #13
Frank_Drebin
Member
 
Registered: Feb 2004
Location: Atlanta, GA USA
Posts: 232

Rep: Reputation: 30
All I did was

chmod 777 /dev/lp0

Its a home network so I don't care about permissions on the printer

Anyway, it didn't seem to change anything at first until I restarted cups. I assumed it wouldn't work but went in to localhost:631 and to mu surprise, it was there.

Now heres the funny part. I logged out of X to reinstall NVIDIA (did a kernel recompile for i686) and when I did I saw lines in console where I had been trying to access lp0 and had no permissions. Once again, had I just configured from command line rather than KDE, I could have saved myself alot of heartache....

oh well, you live and you learn.

good luck!
 
Old 05-21-2004, 10:04 PM   #14
Slacker_Rex
Member
 
Registered: Aug 2003
Location: Arkansas
Distribution: Slackware 12.2
Posts: 104

Rep: Reputation: 15
I just wanted to put my two cents worth in and say thank you. For whatever reason I guess permissions got changed on my /dev/lp0 and my DJ 722c quit working. This has cured it. Thank you very much :-)
 
Old 05-25-2004, 12:02 AM   #15
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Unhappy

hrm seems to still not to work, even with the permissions change and the cups restarting.

It prints perfectly fine in windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP: Cannot Configure CUPS to Recognize Parallel Printer Port as a Printing Device! glaucon829 Linux - Newbie 4 06-05-2007 10:38 AM
no parallel device in lpinfo -v rocordial Linux - Hardware 2 04-02-2005 05:10 AM
cups with no parallel port???? hraposo Slackware 3 09-27-2004 08:46 AM
Parallel port not found by KDE printing manager mediocre_person Slackware 4 05-26-2004 06:41 PM
No Direct Parallel in lpinfo EnigmaX Linux - Newbie 0 02-14-2004 02:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration