LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-14-2004, 12:24 PM   #16
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Rep: Reputation: 30

I've got the same problem with CAB.

Here are my spec's:

ECS L7S7A2 Mainboard
AthlonXP 2800
1 Gb RAM
ATI Radeon 9600 w/ 256Mb

I originally thought it was this new "Natural" keyboard, but after reading this thread, I'll bet we're all plagued by the BIOS on these motherboards...

Just my $.02
 
Old 03-16-2004, 03:32 AM   #17
andreasbergen
LQ Newbie
 
Registered: Mar 2004
Location: Germany
Distribution: SuSE 9.1
Posts: 7

Rep: Reputation: 0
I found some interesting info concerning the CAB-problem:

As it seems it's a problem with AMI-BIOS / SiS-Chipsets.

Here are the links with short exerpts:

http://www.ussg.iu.edu/hypermail/lin...9507/0587.html
> I sent a message yesterday about my problem in exiting X using
> <CTRL><ALT><BS>. I forgot to mention that exiting X with the menu
> options doesn't seem to break anything. Is there a difference in the
> signal generated by selecting menu and <CTRL><ALT><BS> as far as the X
> server/Kernel is concerned?

Check your BIOS and motherboard manuals, AMI BIOS has a feature that
locks up the keyboard and flashes the LED's if the CTRL-ALT-BS hotkey is
pressed and BIOS password is enabled in any way.

Try during any other time while using Linux, you'll probably notice this
exact same behavior, so it's not the fault of X.


http://www.tldp.org/HOWTO/Keyboard-a...e-HOWTO-8.html
Perry F Nguyen (pfnguyen@netcom22.netcom.com) writes: AMI BIOS has a feature that locks up the keyboard and flashes the LED's if the Ctrl-Alt-Backspace combination is pressed while a BIOS password is enabled, until the CMOS/BIOS password is typed in.

On some SiS based motherboards the combination Ctrl-Alt-Backspace will cause a power off, or puts the machine in power save mode. (Reported for SiS 630 and for SiS645DX.)



http://de.shuttle.com/biosbeta.htm#ms21linuxshu
MS21: Linux-Shutdown-Problem bei <Ctrl><Alt><Backspace>

Unter Linux läßt sich der X-Server mit der Tastenkombination <Ctrl><Alt><Backspace> beenden. Bei SiS-Chipsätzen ist diese Code jedoch standardmäßig für das Power Management im APM-Modus reserviert, so daß der Rechner bei dieser Tastenkombination unter Linux abrupt abschaltet. Im ACPI-Modus unter Windows 98SE und Windows 2000 hat dieser Hotkey keine Auswirkung. In der folgenden BIOS-Version für MS21 (ohne Netzwerk) wurde der Hotkey aus dem BIOS entfernt:


http://sdb.suse.de/sdb/en/html/xf86_apm.html
The Machine Shuts Down When Pressing Ctrl+Alt+Backspace

Symptom:

Your computer has a SiS chipset. When you use the short cut Ctrl+Alt+Backspace (e.g., to kill the running X server), the whole machine shuts down instead. This happens on the text console, too.

Cause:

Some motherboards with SiS chipsets have a built-in functionality to shut down the system when pressing Ctrl+Alt+Backspace. This only occurs when using kernels with apm support.

Solution:

First, check if your computer's BIOS contains the option Init VGA-BIOS from S3. If yes, set this BIOS function to disabled.

In case your BIOS does not contain this option, another possibility consists of telling the kernel to switch apm off during the system boot.

This can be achieved by passing this parameter to the kernel:
apm=off

This parameter can also be permanently passed to the kernel through LILO. This can be done by starting YaST2 Control Center and selecting the menu System --> Configure boot mode. Select where LILO should be installed and insert the option apm=off in the text field for Boot parameter (separated from existing entries with a space). Confirm this configuration with Continue and reboot to activate the changes. Alternatively, you can also use YaST (1) in older SuSE Linux systems. Start YaST (1) and select the menu System Administration --> Kernel and boot configuration --> LILO configuration. There you will find the line Append line for hardware parameter, which may already contain some parameters. Insert the option apm=off separated by a space from already existing parameters and confirm with Continue.

The output of LILO will be then displayed in a separate window. You can now exit YaST and reboot your computer.
 
Old 03-16-2004, 03:59 AM   #18
bigearsbilly
Senior Member
 
Registered: Mar 2004
Location: england
Distribution: NetBSD, Void, Debian, Mint, Ubuntu, Puppy, Raspbian
Posts: 3,487

Rep: Reputation: 225Reputation: 225Reputation: 225
Interesting.

However I am getting strange behaviour with an
ABIT IS-7 board which I has an Intel chipset
and I think an Award BIOS.

I have a Gericom laptop too which has a Megatrends BIOS and
also I think Intel chipset.

Both have GeForce FX Gfx cards though.
I sometimes get a sleep/lockup (?) on CAB and sometimes
I get a lockup just after Grub/LILO bootloading.

On CAB i press the power button and it resolves.
I think it's something (maybe?) to do with the switch in framebuffer
modes from X to console.

I've turned off APM in both my Bioses, but no conclusion yet.

billy
 
Old 03-26-2004, 07:03 AM   #19
andreasbergen
LQ Newbie
 
Registered: Mar 2004
Location: Germany
Distribution: SuSE 9.1
Posts: 7

Rep: Reputation: 0
For me CAB doesn't suspend, if I activate ACPI-support in the BIOS (though ACPI-support in the kernel doesn't work and the machine freezes when trying to suspend using kernel 2.4.21).
 
Old 04-22-2004, 09:52 PM   #20
else58
LQ Newbie
 
Registered: Apr 2004
Location: Austin, TX
Distribution: Debian, SuSE, & Yellow Dog
Posts: 1

Rep: Reputation: 0
When I moved from SuSE 9.0 to Debian-Testing on my ECS L4S8A2, Ctrl-Alt-Backspace would exit x-windows and then immediately power off the computer. Quite annoying. It turns out that my "Hot Key Function As" was set to "Power Off" in the BIOS menus.

Although I could not find it mentioned anywhere what key this may be, it is clear it must be C-A-B! I guess Linux use at ECS must be very recent. See:

http://www.ecs.com.tw/faq/faq_spec.a...PRODUCT_ID=194

Ed S.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+alt+backspace marsques Linux - Newbie 2 02-04-2009 01:05 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Cannot use Ctrl+Alt+Backspace to kill X tmorton Linux - Laptop and Netbook 3 11-11-2003 06:25 PM
Disabling <ctrl><alt><backspace> in X redhax8 Linux - General 2 08-17-2003 05:20 PM
Ctrl+Alt+Backspace Socka Linux - Newbie 8 05-18-2003 07:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration