-   Linux - Hardware (
-   -   ctrl-alt-backspace suspends (

wapcaplet 02-28-2004 01:45 PM

ctrl-alt-backspace suspends
This has been annoying me for a while but it's rarely an issue - only on those rare occasions that X for some reason freezes up - for a while now, since installing Gentoo if I recall correctly, using control-alt-backspace to kill X does not seem to work properly. Instead of killing X, it sends my machine into suspend mode. The monitor goes to sleep, the hard drive spins down, and nothing can wake it up - hitting the power button once, using control-alt-backspace again, control-alt-delete - doesn't matter. Computer is in a coma :)

I'm posting this in hardware, because I strongly suspect it's at least partly a hardware problem - my motherboard is an ECS K7S5A; my wife's computer, same motherboard, does the same thing (also in Gentoo).

/etc/inittab has the line:

ca:12345:ctrlaltdel:/sbin/shutdown -r now

And ctrl-alt-del normally works, so I don't think the problem lies there. I'm thinking that some strange combination of this motherboard and Gentoo's configuration is causing ctrl-alt-backspace to be a hotkey for suspend mode.

Weird thing is, I've tried disabling power management in my BIOS, enabling it with some other stuff disabled, etc. Doesn't seem to matter. I don't have any kind of power management enabled in the kernel, and I don't get any other behavior like monitor blanking, hard drive powering down, or similar stuff.

Google searches have not panned out. Anyone else have experiences like this? I'm not too fond of hard-restarting any time there's an X problem. Granted, it's rare, but I'd like to keep my uptimes :)

bigearsbilly 03-02-2004 10:24 AM

you got an nvidia card?

mine hangs on ctrl-alt-bspace sometimes too.
but dab the power button and it kills X.

my laptop is the same, nvidia GeForce, SuSe 9.
also hangs on boot occassionally.

both my laptop and desktop do it.
sorry no help but I'm suspicious these GeForce cards may be the problem.


wapcaplet 03-02-2004 12:34 PM

That may be it too - both computers have GeForces. Curiouser and curiouser... I'm trying to recall whether it happened before I got the GeForce. I'm fairly sure that it worked when I was still using Mandrake; I suppose if it is the GeForce, it may be related to the drivers (which have been updated since then), or possibly Gentoo's particular configuration for the nvidia drivers. But then, if you've had it happen with SuSE, it's probably not Gentoo-specific.

You say hitting the power button kills X? I'll have to try that next time I have a problem.

flysideways 03-02-2004 12:58 PM

Well, my K7s5A has a Radeon 8500 in it and FC1 and when I hit ctrl+alt+backspace it went into a suspended mode. Hitting the spacebar was all that it took to bring it back but then I had to log back on again. Does that mean that it also shut down X or is that normal for suspend in Linux?

wapcaplet 03-02-2004 01:51 PM

Well, control-alt-backspace is supposed to simply shut down X; if you were logged in via a graphical login screen (like KDM or GDM), then that would mean logging in again. If you'd started X with 'startx' from a console, then it should just go back to the console. At least, that's what it used to do before I had this problem. Used to be, whenever I had something in X lockup, all I had to do was ctrl-alt-backspace, and I could recover without rebooting. Now, since it seems to go into permanent suspend, it means I gotta reboot. No fun at all. It's like running Windows (only it doesn't happen as frequently).

wapcaplet 03-02-2004 02:24 PM

After poking around in my BIOS a little, I'm almost certain that it's my motherboard causing the problem. Under power management, there's an option for keyboard power-on. The "help" screen says this:

Keyboard PowerOn Function
If set to Specific Key, [CONTROL-ALT-BACKSPACE] is only one PowerON event. If set to password, please press Enter to input password and its maximum password is 5 character.

Reading between the broken English, I think what this is saying is that ctrl-alt-bksp is automatically intercepted by the BIOS for keyboard power-on events (and apparently also for suspending). It doesn't work unless a particular motherboard jumper is set, in order to enable keyboard power-on. I had it disabled. For kicks, I tried enabling it; no difference. ctrl-alt-bksp still suspends, and nothing aside from hitting reset or the power switch can bring it back to life. Ctrl-alt-bksp apparently always means "boot up" or "suspend" to the BIOS, completely irrespective of what my power management config is set to - even if it's disabled entirely.

I guess the only other option might be finding a different hotkey combination for killing X, but I suspect that's the kind of thing that's hard-coded.

By the way, hitting the power button once did the exact same thing - suspend with no hope of recovery.

Ah well. Guess I'll learn to live with it.

slakmagik 03-02-2004 05:17 PM

You could uncomment 'Don't Zap' in XF86Config, I believe. That way CAB won't work, I think. Then maybe create a scriptlet to kill X your own way and bind it to some other key-combo. Then you could see if it was a CAB issue or a n X-kill issue. If it was an X-kill issue, rather than a key issue, and couldn't be resolved, maybe you could rebind CAB to execute your script and it'd be transparently identical in function.

Just some ideas, though I'm not sure how workable.

bigearsbilly 03-03-2004 03:26 AM

Maybe it's the switch to svga console mode?
so other people have the problem eh?

BTW, I've had the hang exiting X gracefully (as they say) rather than the usual ctrl-alt-bspace, so it's not specifically that key sequence.

The first thing to try is to just blip the power button. that usually works.

as George dubya might say: I have being investigatorizing

I noticed on the laptop that with the ctrl-alt-backspace in X, when it hung, put the little 'sleep mode' light on when this happened. So this is probably what happens with the desktop too. It's putting it to sleep.
It's strange how it's only occasional too.

I am also getting the sleep mode (?) sometimes on startup, just after LILO/Grub
(tried both) before the kernel load, *WELL* before init starts. So it does no damage, no fsck needed just a very annoying reset.

Typically in the morning I will need 3 or 5 resets before i get a clean boot.
(Is the card warming up? Or is that just nonsense?)

This morning I tried, same problem. Then I put a "vga=normal" as a boot parameter and it booted fine. Allthough it's now a hideous 40x80 MSDOS font on my console, making that pretty unuseable.

So I am suspicious that both my problems are something to do with the card switching to the SVGA console mode (whatever it's called).

This would explain, suspending on boot, and suspending on X exit.


bigearsbilly 03-03-2004 03:48 AM

let's get this sussed

The BIOS thing is a worry. which would imply we are jigger'd (to coin a phrase)

But i'm sure (am I?) I've had it exiting X the slow way.
I'm not sure if I've not had it with a kill either. (tried it all)

Maybe we can all try exiting X all possible ways, clean and dirty and pool our results.
Then if it's the same we can eliminate the key sequence itself from the enquiries.

Is no one else getting the same on boot-up?
Is it related or just coincidental.


bigearsbilly 03-03-2004 04:56 AM

check this thread.
megaman says something about frame buffer support.

anyone know what that is exactly?


wapcaplet 03-03-2004 10:37 AM

I'm fairly sure it's nothing to do with SVGA modes or framebuffer support in my case; I don't have anything special by way of video modes in my /etc/lilo.conf (in fact, I tried it once but had console respawn problems; I don't spend enough time in console to make it worth fixing) - so anyhow, just boring 80x40 on my consoles.

I've also never, that I can recall, had any trouble exiting X normally. Given that my BIOS seems to be looking for ctrl-alt-backspace for suspending, I gotta think that it's a BIOS problem, and that it is definitely specific to that three-fingered salute.

I'll poke around my mainboard manual and see if I can find more info about this BIOS. Maybe there's an update to it that will help fix it...

andreasbergen 03-10-2004 05:31 AM

ctrl-alt-backspace suspends always!
I've got a K7SOM+ v5.c Mainboard and have the same problems. It always suspends when pressing Ctrl-Alt-BS. It did even when I pressed CAB in grub (before any linux-kernel was loaded) and even at the very first question when booting off a win95 install-CD (start from Harddisk or start from CD?)

Seems to be that the BIOS catches any CAB-press and suspends whatever is set in the BIOS-settings.


The problem for me is that it doesn't resume well after a suspend very often: Many times it suspends and hangs or it oopses after the second suspend. I tried several different kernel (2.4.21-99-athlon, and vanilla 2.4.22-25) all hang or oops after one or more suspends... Any help?

bigearsbilly 03-10-2004 05:50 AM

I've tried with acpi=off no diff.
But for me, it doesn't always happen. most time CAB to quit
X is fine, only occasionally. Sometimes boots okay, sometimes doesn't. On laptop has gone to sleep on startx.
press power, it starts. weird!

Tried debian on laptop, didn't seem to happen (which does an i386 kernel - i assume to mean not pentium hyperthreading and all that old malarkey)

Obviously lots of people having this prob.
I'm suspicious of my nvidia card.
or is there a kernal bug?


andreasbergen 03-10-2004 07:27 AM

I don't know if many people have this problem. The last weeks I installed SuSE 9.0 on two other athlon/duron machines (don't know which mainboards). Both had a problem with Ctrl-Alt-BS. I'm not sure whether they suspended or not (they were not my machines) but it happened occasionally that they locked / oopsed after pressing Ctrl-Alt-BS.

As I saw in this thread at least two others had a K7S...-mainboard. Hardware-Problem?

Is there a problem with the suspend-/powermanagement-code?

slakmagik 03-11-2004 03:01 AM


Originally posted by andreasbergen
As I saw in this thread at least two others had a K7S...-mainboard. Hardware-Problem?

Nothing useful to contribute - just saying I have a 'K7S5A Pro' and don't have problems with CAB (which I hit a lot as I frequently get annoyed with X). So if it's a mobo problem it's specific mobos or a combination of factors.

All times are GMT -5. The time now is 10:32 PM.