LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-12-2006, 10:44 AM   #1
afrodocter
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 110

Rep: Reputation: 15
crash on toshiba satellite a105, gentoo


i have installed a windows/gentoo dualboot on my toshiba satellite a105-s2712. the problem is that it will shutdown after about 20min-1hr after it is on, only when in linux . after it shuts down it will not turn back on for about 10-30sec. it shuts down with and without the ac-adapter plugged in. once it has shut down i tried taking the battery out and pressing the on button with and without the ac-adapter , then putting back in the battery and hitting the power button. non of this seems to have any effect. i think its a low-level power managment problem but im not sure what to do.
im running a custom compiled gentoo kernel 2.6.15-gentoo-r7.
i have acpi enabled.

thanks for any incite.

alex
 
Old 07-13-2006, 01:46 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,621

Rep: Reputation: 98
Do you see anything suspicious on any log?
 
Old 07-20-2006, 08:08 AM   #3
afrodocter
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 110

Original Poster
Rep: Reputation: 15
no. the log stops when it shuts down. so i am not sure how to troubleshoot it.

however i recently got a new 2.6.16-suspend2-r11 kernel and compiled it a little different, according to suggestions on getting suspend to work. (used uhci_hcd and ehci_hcd as modules) im not sure it this was it. but it is not crashing anymore so i am happy.
another un-ordinary thing i had to do, which may or may not create instability, was remove and install a newer version of ieee80211 support in my kernel for my wireless driver ipw2200. this was instructed by portage and the driver works great.

thanks for the help.

alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Satellite A105-S2101 I need Help Odin5578 Linux - Laptop and Netbook 7 09-06-2006 02:16 PM
Solaris on Satellite A105-S2101 Odin5578 Solaris / OpenSolaris 1 07-05-2006 02:08 AM
10.2 install on Toshiba Satellite A105-S4004 DennisTheMenace Slackware - Installation 14 06-05-2006 11:28 AM
Toshiba Satellite bigredgiant1 Red Hat 8 09-02-2003 10:11 PM
Toshiba Satellite teamstatic84 Linux - Laptop and Netbook 1 07-21-2003 05:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration