-   Linux - Hardware (
-   -   crackling/popping sound on Intel Corporation Sunrise Point-LP HD Audio (rev 21) (

zeebra 08-17-2019 07:22 AM


Originally Posted by business_kid (Post 6008036)
I have the Intel Panther Point (I HATE stupid software names). That's Series 7.

Back in 2015, I had to get HDMI Audio, and it sucked real bad. It sounded like I was getting square waves instead of sinewaves to my low-fi techie's ear. Bu8t a guy here said it needed resampling. So the sound came at 44khz, was re-sampled at 48khz, and that sorted it. I still have the .asoundrc, and a script to tweak so that hdmi sound went to the earphone jack plug (I know, I know - There was a good reason for that).

I've not actually figured out how to resample the sound. This is one of the things I wanted to try. However, doing any equalizing or re-sampling in the systemD times of oversimplified and complicated solutions to everything, seems to be near impossible. As far as I've researched, there is no longer any existing system-sound-equalizer in GNU/Linux (alsa/pulseaudio)..

I did try to look into resampling the sound, and I think I even tried a few things, but with no success. As far as I remember it either stayed at the same sample frequency or did nothing at all. It seems to be almost as complicated as trying to find a system equalizer. Any concrete indications of a working alsa/pulseaudio re-samling would be much appreciated. Or any pointers to somewhere I can find an actual working solution.

Anyways, this issue keeps haunting me from time to time. The sound if actually mostly working, but sometimes it's just terrible with cracking/popping sounds all over the place. In particular I've noticed that this problem is present whenever I watch a video where people speak into some kind of microphone. So I think I've narrowed the issue down a bith further to that, but I'm not 100% sure. I might have with some of the solutions above manage to solve the random popping issue as I haven't heard this much recently. Now it's mostly the crackling issue left, or only.. It's a bit difficult to say and it is near impossible to say that I've resolved the popping issue and which solution solved that, sadly.

Working with this sound issue, I've found out that trying to deal with sound is a bit diffuse. It's difficult to make things concrete for others to understand. It is also difficult to deal with Alsa and Pulseaudio to try to resolve possible issues that one might experience with sound. There are very few useful utilities, and very few sound functions in both Alsa and Pulseaudio. A clear degredation to how things were before. Sound was more complex and you had more tools and utilities. But perhaps I remember it wrong.

Anyhow, I think the saying is "do one thing and do it well", not "do one thing and simplify it to the max". I think Alsa is excellent and they do one thing and do it well, but sadly I think in that mission they have sacrificed some complexities and oversimplified the system for the user, in favour of making it easier for the developers. I could be wrong in saying that, but it would be understandable at least if they made the decisions for that reason, rather than just dumb things down for the user and offer them less tools and utilities for no reason.

Pulseaudio does one thing in a very stupid way is my impression. And the commands etc do deal with pulseaudio is very un-unix like. Isn't the point of pulseaudio just to split hardware sound and offer this as a service to multiple output/inputs? Then why does it have to be so damn complex? Why not just do one thing and do it well? I think perhaps systemD answers that question. Do everything and do one thing well, but everything poorly, that is the policy of the day.

It would be nice to have an alsa sound server instead, one that does what pulseaudio tried to do. Now we end up with two things that do one thing, and none of them have the toos and utilities to satisfy the user and more complex needs.

Ok, so this post turned into some kind of rant, my apologies. I'm just a user, and from a user perspective it does work well in general, but it's overly complex and offers users no real satisfaction and control over things. Even something as simple as shutting down pulseaudio is like trying to dethrone a tyrant.

business_kid 08-18-2019 05:32 AM

This was given to me in 2015, in my pre-pulse days. I was trying to achieve 2 things
  1. Do something about the %&@! awful hdmi sound
  2. Find a way of diverting hdmi audio to the jackplug to facilitate simultaneous translation.

Sound on that <insert your choice of expletives> Intel card was at 44khz. The 48000 changed that to 48khz, and the effect was magical. I think the redirection to jackplug was done with a script which dropped in another config file, or pulled it out. I had it licked on my box, and no windows or Mac user could do it, so they all had to use linux for the day. Here's the ~/.asoundrc

pcm.hdmi_hw {
  type hw
  card 0    # <--- card number
  device 3  # <--- device number

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hdmi_hw"
buffer_size 32768
rate 48000
period_time 0
period_size 1024
buffer_time 0

pcm.rate_convert {
type plug
slave { pcm "dmixer"

pcm.hdmi_complete {
  type softvol
  slave { pcm "rate_convert" } "Master"
  control.card 0

pcm.null_capture {
  type null

pcm.!default {
  type asym
  playback.pcm {
    type plug
    slave { pcm "hdmi_complete" }
  capture.pcm {
    type plug
    slave { pcm "null_capture" }

Your device numbers probably won't be the same, but otherwise try leaving it and see what damage it does. How it will interact with pulse is another matter.

The other thing not to overlook is blown speakers. a lot of overdriving or use at full volume blows speakers, quite frequently especially on laptops.

zeebra 08-18-2019 06:00 AM


Originally Posted by business_kid (Post 6026372)
Your device numbers probably won't be the same, but otherwise try leaving it and see what damage it does. How it will interact with pulse is another matter.

The other thing not to overlook is blown speakers. a lot of overdriving or use at full volume blows speakers, quite frequently especially on laptops.

Thanks for your input, I'll have a look into that. I don't think the speakers are blown, it was a new laptop and the sound was like this from the beginning. It does kindof sound like blown speakers, but I doubt it is. I'm pretty sure it's not infact. I'm 99% sure it is a "sound processing" issue. I recorded a file on this computer and transferred it to another computer without any sound issues, and the issue was then the same on the other computer with the file processes on this computer.

So, I pretty much concluded it HAS to be a sound processing issue, and that is probably either down to poor/defect hardware OR poor/defect/non-working driver or otherwise software. I'm not 100% sure it is possible to solve with software, the issue could be hardware, but I have a feeling it could be possible to solve with software, but it could be down to the driver itself, and in that case I cannot fix it myself.

Pulse and Alsa makes things more difficult to pinpoint, so there is definetely a very annoying aspect of interaction with pulse, even if pulse is not the issue. To further isolate pulse or alsa as the source of the issue, I need the same soundfile processed on my ALSA-ONLY (non-systemd) distro to isolate the sound processing to ALSA. However, right now that is an issue, as this distro is seriously lacking my attention and need a bunch of stuff installed to be able to process the video/sound codec. I imagine that will be a job in and of itself. But once that is done I can narrow it down to alsa or pulseaudio.

However, I think I'll need to try some other steps before that, as it might take awhile with the current situation of that distro and the amount of work it would be to get the correct codec installed to even be able to process the video/sound file with that distro. Not to mention that I have to deal with manually getting the wifi network up on that distro every time, and disable pulseaudio yet again.

I hope in the end I can resolve the issue and that this thread might be a goto for other people who experience the same issue. I've still got alot of work ahead of me to reach that point. Fixing diffuse sound issues is not exactly the easiest thing as you might see from all the effort I already put in.

sidenote: playing a normal video file yesterday with some added music, I had the same issue with the crackling sound, so it is NOT ONLY with microphone recorded content as I speculated earlier

business_kid 08-18-2019 11:59 AM

If it's dud speakers, turning the volume down should help. In fact it's always a good idea to try it at low volume.

zeebra 08-25-2019 08:14 AM


Originally Posted by business_kid (Post 6026501)
If it's dud speakers, turning the volume down should help. In fact it's always a good idea to try it at low volume.

It's not the speakers, volume doesn't make any difference in regards to the bad sound. It MIGHT be a faulty card/circuit, but I have a feeling it is not. I'm 99% sure this issue is "sound processing" as it even carries over into different systems after processing the sound using this system with this card.

Testing with another distro is something I plan to do, but has not yet got around to. Processing with Alsa only is yet another test I will make. Possibly trying a pre-4.14 kernel as well. I guess these tests should narrow down the problem further.

Fixing my test environment Slackware with the correct codex to actually investigate and process the same video/sound files will accomplish these two tests. It's just that I have to find out about the codec stuff, and I don't exactly know a whole lot about these codecs and encoders etc and which ones will actually process the particular test video/files that I'm trying to deal with.

If anyone could point me in the right direction, the files are played on and downloaded from youtube. Probably it is mp4a (aac) and vp9 (or possibly h263, h264). I think I'd need vp9 encoder and aac encoder only.

business_kid 08-25-2019 01:39 PM

Codecs are unlikely to be the issue. They're a whole area to themselves. There's a basic set with the soundcard, and others are optionally added. I thionk my soundcard has Realtek codecs, and never gave trouble. This is at least my 2nd soundcard to have Realtek codecs.

To fault find, stick with something bog simple, like aplay & arecord, where you can play & record, and set the rate you record at. You can take codecs for granted there, unless something is majorly defective. Man arecord for it's options, record a .wav from your phone or some such, then aplay to hear it. BTW, have you Skype? How does that work?

zeebra 09-03-2019 09:24 AM

So, in a twist of turns, when I updated my whole distro to a new version (new install) the issue "magically" went away.

I marked the thread as solved, although the issue is not really "solved", since I do not know what caused the issue in the first place. Anyways, someone with similar problems might try the same solution. Sadly I have no idea which software caused the issue and which "new version" solved it. But the newest version of software X, Y, Z should solve the issue.

Not only is the Kernel new, but I assume new versions of Alsa and Pulseaudio is also installed, and I know I have a new version of Firefox. Those are the main suspects in the first place. Additionally I've installed a bunch of codecs etc in their new versions.

My personal issue is solved, but I might continue to investigate this issue to find the root of the issue, but I would need to install a version of the old distro again. I think the old version will have the same issue as before, as my "old version" was a fresh install on new hardware in the first place.

I use a persistent /home folder, so the issue was not due to local settings or anything like that.

zeebra 09-03-2019 09:37 AM

According to distrowatch some selection of software versions that might be relevant:
- Alsa moved from to 1.1.7
- Firefox moved from 60.x to 67.x (esr)
- Kernel from 4.9.x to 5.2.x (current 5.2.10)
- Systemd 230 to 241

not sure about pulseaudio on the old version, but current is 12.2

All times are GMT -5. The time now is 05:31 PM.