LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   could not detect partition or filesystems installing fedora (http://www.linuxquestions.org/questions/showthread.php?t=4175443371)

filippogiuliani 12-29-2012 11:01 AM

could not detect partition or filesystems installing fedora
 
Hi guys, i have a macbook and i'm trying after deleting windows to install a linux distribution. I can't use boot camp couse it will work only if you have just one partition on your disk. So i tried to install debian but it stopped three times looking for a disk. Then i tried with fedora that gently said me: we could not detect partition or filesystems on this device.
I tried to create a FAT partition over the free space, nothing.
I tried to sync gpt by gptsync, nothing.
What can i try?

Code:

MacBook-di-Filippo-Giuliani:~ filippogiuliani$ sudo gptsync /dev/disk0

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1            40      409639  EFI System (FAT)
 2        409640    208126167  Mac OS X HFS+
 3      208126168    209395711  Mac OS X Boot
 4      209395712    459302911  Basic Data
 5      459304280    976510983  Mac OS X HFS+

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1      409639  ee  EFI Protective
 2        409640    208126167  af  Mac OS X HFS+
 3      208126168    209395711  ab  Mac OS X Boot
 4      209395712    459302911  0c  FAT32 (LBA)

Status: Tables are synchronized, no need to sync.

MacBook-di-Filippo-Giuliani:~ filippogiuliani$ diskutil list
/dev/disk0
  #:                      TYPE NAME                    SIZE      IDENTIFIER
  0:      GUID_partition_scheme                        *500.1 GB  disk0
  1:                        EFI                        209.7 MB  disk0s1
  2:                  Apple_HFS Mac Os X                106.4 GB  disk0s2
  3:                Apple_Boot Recovery HD            650.0 MB  disk0s3
  4:      Microsoft Basic Data LINUX                  128.0 GB  disk0s4
  5:                  Apple_HFS Data                    264.8 GB  disk0s5


bigrigdriver 12-30-2012 01:28 PM

This leads me to suspect that hardware is the problem and not the distributions you have tried.

Does your Macbook have Intel or AMD compatible hardware, or is it the Motorola hardware?

If it Motorola, you will have to download a distribution which runs on that hardware.

filippogiuliani 12-30-2012 03:04 PM

It's an Intel Core 2 Duo. It's the right version, i have already install fedora 16 once. And i have already tried the wrong version (amd64 it's so confusing I always forgot) it wouldn't boot.

if you wanna info about hd:

Code:

MacBook-di-Filippo-Giuliani:~ filippogiuliani$ diskutil info /dev/disk0
  Device Identifier:        disk0
  Device Node:              /dev/disk0
  Part of Whole:            disk0
  Device / Media Name:      WDC WD5000BEVT-22A0RT0 Media

  Volume Name:              Not applicable (no file system)

  Mounted:                  Not applicable (no file system)

  File System:              None

  Content (IOContent):      GUID_partition_scheme
  OS Can Be Installed:      No
  Media Type:              Generic
  Protocol:                SATA
  SMART Status:            Verified

  Total Size:              500.1 GB (500106780160 Bytes) (exactly 976771055 512-Byte-Blocks)
  Volume Free Space:        Not applicable (no file system)
  Device Block Size:        512 Bytes

  Read-Only Media:          No
  Read-Only Volume:        Not applicable (no file system)
  Ejectable:                No

  Whole:                    Yes
  Internal:                Yes
  Solid State:              No
  OS 9 Drivers:            No
  Low Level Format:        Not supported

MacBook-di-Filippo-Giuliani:~ filippogiuliani$


filippogiuliani 12-30-2012 03:05 PM

What's that
Code:

OS Can Be Installed:      No
that i'm noticing now.


All times are GMT -5. The time now is 03:22 AM.