-   Linux - Hardware (
-   -   Connecting Suse Linux to ISP via D-Link DSL-G604T (

Taffy 05-27-2006 12:05 AM

Connecting Suse Linux to ISP via D-Link DSL-G604T
I have recently installed Suse 10 onto one of two machines. Both machines run Windows XP, the one I'm working on dual boots with Linux. The two machine LAN is connected via a D-Link DSL-G604T router, no trouble whatsover when both are running XP. When I boot this machine on Linux there is no connection to the net, LAN or WAN, the ADSL is obviously connected as the other machine sees it (connected via a G-Link DWL-G520 Wireless adapter) and running the 604T setup program 'status' shows that the ADSL is connected. My Linux machine has now been set so that its DHCP is off, the ethernet card (D-Link DGE-530T) is set to accept its IP address from the router (I think??) but no connection is made.
As the router controls IP addressing am I correct in assuming that the Linux DHCP is left out of the equation?
How can I check that the ethernet card is correctly given a correct IP address?
I have spent a couple of days looking through as many forums as I can, including D-Link and Suse, and the threads heading this 'new thread' without success. It would seem to me that there must be a VERY simple answer to this problem, but that I am too simple to see it.

Many thanks for any answer given.

fotoguy 05-27-2006 05:27 PM

Actually the DHCP that SuSE 10 is referring to is the DHCP client daemon, this is the little program that gets the ip-address from a DHCP server, so you need to activate it otherwise your need to set the ip-address statically. To setup automatic addressing:

Goto main menu (little green icon bottom left corner of screen) --> System --> Control Center (YaST)
Select Network Devices --> highlight you network card --> then click the edit button
Then select the 'Automatic Address Setup (via DHCP)' --> cleick the 'Next' button folow the direction. Then restart your machine.

Taffy 06-01-2006 10:10 PM

Thank you fotoguy, i had set up my ethernet card exactly as you have suggested.

I have now found that I have a connection, but it is dreadfully slow. Only Novell, the Suse default, has connected, and that only once. All other URL's drop out with a 'out of time' error before connection. Novell was unusable because it time out when trying the next page.

Ping several addresses produced the following:
Loopback: 95ms
Yahoo: 192ms
Google: 345ms

Others were in the same area.

I obviously have something wrong with my Linux setup causing a clash of some sort, but I lack the knowledge to find the answer, however much I read. After a while I get even more confused, must be something to do with my old age!

The DHCP of Linux is off.

Hopefully someone has the skills to assist.

Regards to all who read this.

fotoguy 06-02-2006 02:23 AM


Originally Posted by Taffy
The DHCP of Linux is off.

Strange, that should be working if it's selected. Never had a problem myself with SuSE, it's always worked right from scratch.

Taffy 06-02-2006 09:00 PM

Thanks fotoguy. It is now resolved and this question can be closed.

I finally went back into the D-Link router `and reset to factory settings, I then set up the WAN and LAN as I believed it should be and set it's DHCP to enabled. Everything worked as it should following a reboot.

My assumption that it must be the Linux OS was unfounded, it appears that settings are provided for Windows operation, in this case XP. It is quite aggravating that companies like D-Link ignore other OS requirements. My apologies to Suse, it was only waiting to get incoming info correct.

Although I have used Suse for 2 years, this is the first time I've connected to a LAN, I do not have any knowledge of Linux outside of the GUI, I am long retired and too long in the tooth to get my head to remember things as well as I did as a young man. Suse has always worked brilliantly for my needs and I have no complaints there, I just wish third party software and hardware houses would get as switched on as Hewlett Packard.

Thank you once again fotoguy, your generosity with time is much appreciated.


fotoguy 06-02-2006 11:24 PM

Good to hear it's all sorted out, glad to help out.

All times are GMT -5. The time now is 01:51 AM.