LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Conflicting sound HW? (http://www.linuxquestions.org/questions/showthread.php?t=4175476265)

fargris 09-07-2013 04:39 AM

Conflicting sound HW?
 
I have recently bought a webcam - "Novatek Microelectronics Corp." (from lsusb); on the label it says TWHD-211. I have a desktop from Dell (Optiplex 3010) and the soundcard is "Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)" (from lspci).

Before I got the webcam, the sound worked fine, straight out of the box - I'm running Debian 7, 64 bit and KDE. I hade some trouble with the microphone, but got it to work by going into alsamixer and unmuting it.

I then got the webcam and got it work with skype and google hangouts; so far so good. That was yesterday evening - I used google hangouts for a couple of hours yesterday, and before that, skype. Now, wen I boot up, the speakers are dead and the microphone is too.

When I look in Phonon, I see the speakers should be fine; but no sound when I press the test button. The "Audio recording" tab shows two input devices, the built-in sound card and the webcam's microphone; the built-in one is grayed out and the webcam isn't. Recording doesn't work. If I unplug the webcam and reboot, the webcam still shows up, but grayed out. And still no playback/recording. And alsamixer seems to be correct.

What is going on here?

business_kid 09-07-2013 08:57 AM

Don't know. Try opening /etc/asound.state for editing and see if anything is switched off. It might work better if you booted with no webcam, plugged in the webcam, and then loaded it's module (at a guess, uvcvideo).

fargris 09-07-2013 10:25 AM

Hmm, I don't have /etc/asound.state - or indeed anything called asound, it seems.

When I reboot without the webcam, the speakers work, and so does the microphone, but in phonon both the built-in sound card and the webcam are listed in grey. Something here is not working right, I feel. Should it not be possible to go in and manually disable the webcam's microphone and enable the sound card's? This is possible in Windows, or so I'm told.

business_kid 09-07-2013 11:37 AM

Maybe the issue is with phonon. Do other things see it? (skype, for instance).


All times are GMT -5. The time now is 09:35 PM.