LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Configuring Wacom Graphire4 on Mandriva (https://www.linuxquestions.org/questions/linux-hardware-18/configuring-wacom-graphire4-on-mandriva-414288/)

Carroarmato0 02-11-2006 03:54 PM

Configuring Wacom Graphire4 on Mandriva
 
Hello,

I can't seem to get my Wacom device working with Mandriva.
So far I've found some clues:

+The kernel has a driver named "wacom" which is loaded at startup
+The device is found, but I'm not sure if the driver "wacom" claims it.

From what I understand is that "event2" and "ts1" are my tablets input.
Indeed when using a cat command on them I get a response on my console.
I've tried adding the proper strings in the XFree86 configuration file and Xorg, but
with no result except for my usb mouse not responding or somethimes
the whole XFree server doens't start. I've also tried to follow the Linux Wacom Project's
documentation but without any result( not much experience).


Is there still anyone who can help?

Carroarmato0 02-18-2006 12:32 PM

Update: wacom kernel driver claims my Wacom device, but still nothing happens While looking around on da net I found some other clues: it would appear that my tablet works on any other system other than Mandriva 2006. My conclusions are that the kernel of Mandriva 2006 2.6.12-12mdk isn't supporting it, while older and newer versions of the kernel 2.6.12 do. Should I wait for the next release of Mandriva or is there another solution?

dangerboy 10-18-2006 01:32 PM

Here's a late solution.
 
You may or may not have fixed this, but I just recently had this problem on Slackware 11 (kernel 2.6.17.13) with a Graphire4. I fixed it by getting the 0.7.6-1 production drivers, compiling, and installing. I posted this hoping to benefit someones sanity, as I know finding a solution can be frustrating.

I had this same issue. I would do a:

Code:

wacdump /dev/input/event#
and the kernel driver was reading my wacom as it should (all coordinates, switches, and pressure). The X driver on the other hand was not reading at all. I'd point to the appropriate device in xorg.conf, but no dice. Why? I haven't the faintest idea, but an upgrade worked. Maybe the kernel driver and the x driver weren't communicating properly (thats a left field guess).

This is the link to the Driver I used.
http://prdownloads.sourceforge.net/l....7.6-1.tar.bz2

Make sure you compile it using the X11 SDK.
http://rpmfind.net/linux/rpm2html/se...y=xorg-x11-sdk

And follow this guide, it's for Ubuntu, but it works.
http://ubuntuforums.org/showthread.php?t=25151

Once you've untar-ed the driver and installed the SDK, it's a ./configure, make, make install (or checkinstall if you want to keep track) routine to get it installed. Configure your X11 config file, per the directions in the Ubuntu guide, reboot your machine and re-enter X and it should work.

Good Luck.

Edited: for Clarity.


All times are GMT -5. The time now is 01:35 AM.