-   Linux - Hardware (
-   -   Configuring my sound card in Slackware (

Tayl 02-19-2003 09:39 PM

Configuring my sound card in Slackware
I'm sort of a nOOb when it comes to using GUI's and sound in Linux...all I've ever done is run web and mail servers with slackware. But now I've decided to do a dual boot with Windoze XP and Slackware. I even got my dual monitors working. :D

My desktop looks nice, but I still don't have sound, and quite honestly, I have no idea where to start. I looked around the 'net, and searched here, but couldn't find any good explanations of what exactly I should do to get my sound working. I have NO sound: No music, no CD, nothing. When I try and open a .Mp3 with XMMS, I get this error message:

Please check that:
1.) You have the correct output plugin selected
2.) No other program is blocking the soundcard
3.) Your soundcard is configured properly

Now, I know this is probably pretty simple, but I've NEVER had to configure sound in Linux. Sorry in advance if this is really stupid...if you could just point me in the right direction, or give me some help, I'd really appreciate it.

Oh, I almost forgot. My soundcard is a Soundblaster Audigy in my PCI slot, and it works perfect under Windoze. Thanks!

Palin 02-19-2003 09:43 PM
You may have to look around for the packages for your system but it seems to be the best solution for sound that I have found for me at any rate.

Tayl 02-19-2003 09:47 PM

Figures that two minutes after I post here I figure it out. :rolleyes:

I went and found a HOWTO right after I posted, and followed the instructions. Now the Chili Peppers are rocking my world on Linux. :D

Thanks again!

matruschka 03-01-2003 10:00 AM

Hi Tayl.

Since I get the same error message when trying to get sound in my non-root shell acount I'm curious where you found the howto you´re reffering to?Maybe I can find some hints there as well...

thanks in advance

Tayl 03-03-2003 01:46 AM

Yeah, sorry, I haven't checked my old posts in a while. I'd be happy to give it to you...just let me go find it. :D

EDIT: Alright, I found it pretty quick. Here is the link: SB Soundcard HOWTO

It is one of the help files over at They have some good nOOb files for setting up your system for the first time. I have a Soundblaster Audigy, and this worked perfectly for me.

One last thing: I had to add a startup script in order for this to actually work after I reboot. I don't know if this was the best way to get this to work, but in Gnome there is a place in the startup configurator that lets you enter commands that will run when Gnome starts up(if you need help setting that up, just post it here. I'm not in Linux at the moment and don't remember exactly how I did this, but I would be more than happy to give a step by step if you are stuck). I had the "modprobe emu10k1" command at startup, and that made sound work OK. There is probably a better way to do this, but...that's what worked for me. Hope this helps!

All times are GMT -5. The time now is 10:30 AM.