-   Linux - Hardware (
-   -   Computer suddenly running really slowly, please help (

rockergrl 12-05-2004 03:37 PM

Computer suddenly running really slowly, please help

About 3 weeks ago I was using the internet on my computer (Toshiba laptop, running Fedora Core 2). The computer basically crashed, I could move the mouse but I couldn't click on anything. I restarted the computer, and since then my computer has been running ridiculously slowly. Before this I had no problems for about a year with running Fedora.

I tried reformatting because I needed to do this anyway, however this had no effect, which has brought me to the conclusion that I have a hardware problem.

This is what I've noticed from watching top over the course of the last few weeks:
My load average is normal if I am not running any processes. It stays about .4. If I run anything xmms, mozilla, etc it jumps to 2.00-3.00. The more I run, the higher it goes. If I have mozilla and xmms open, the computer is too slow to do anything. The strange thing is that memory and cpu usage stay reletively low. And, even if a lot of memory is used, the swap memory is never touched. This is the first time I have tried to debug a situation such as this so excuse me if this information is not relevant or helpful.

Please, if you have any idea what could be causing this problem let me know. Also, if there is anything I can do to lead me in the direction of having this fixed, please let me know.

Hiper 12-05-2004 03:58 PM

Maybe it has something to do with cache (check bios options)
or maybe it's something related to clock speed (there should be some information in /proc)

J.W. 12-05-2004 04:18 PM

Welcome to LQ. Were you doing anything in particular immediately prior to the crash, such as installing new hardware, updating software, installing new software, etc. Any background info about what was happening before the crash may yield a clue.

Secondly, when you say you 'reformatted" alteady, do you mean you completely wiped the hard drive, and reinstalled from scratch? Please clarify.

As for possible causes, I'm just guessing but it sounds like either you've got a variety of unneeded system processes running which are consuming resources, or maybe one of your RAM sticks has failed. A dramatic reduction in system performance could be the result of a reduction in the amount of (usable) RAM. Are there any error messages during bootup? -- J.W.

rockergrl 12-05-2004 04:33 PM

Hi, I was playing poker using a java applet from a website when my computer crashed. This is something I do all of the time without a problem.

When I say reformatted I mean I completely wiped out the hardrive and reinstalled the os. I doubt the problem is the processes running seeing as how I did this.

There are no error messages during bootup.

The first thing that occured to me also was a memory problem, how would I check this? With a desktop I would just take a memory stick out and reboot, but I'm not sure about the internal makeup of a laptop.

J.W. 12-06-2004 11:44 AM

If you have totally reinstalled the OS, then we can safely ignore the scenario of extra processes running. Perhaps this could be a RAM issue, and to test your RAM, I recommend Memtest86. Basically it will cycle through a variety of exercises designed to work all memory cells in your RAM. It can take several hours to complete several full cycle tests (generally you should let it do at least 2 or 3) and therefore I'd suggest just letting it run overnight. If there are problems found with RAM, then the solution would be to replace it (obviously) but if none are found, then (again, equally obviously) the cause is something else.

Has system performance returned to previous levels (now that you've reinstalled) or is it still as poor as it was when it first came to light? -- J.W.

rockergrl 12-08-2004 01:26 PM

thanks everyone for suggestions thus far. I ran Memtest86 and no errors were found.

System performance is still very bad. If I try to run anything on my computer it gets really really slow.

Anyone know what could be wrong if RAM is not the issue? Or, does anyone have suggestions on anything else I can do to figure this out?

All times are GMT -5. The time now is 02:11 AM.