LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   compaq says no to linux (https://www.linuxquestions.org/questions/linux-hardware-18/compaq-says-no-to-linux-329836/)

danieljames 06-03-2005 03:20 AM

compaq says no to linux
 
I have come across some compaq machines that wont accept linux. At start-up the computers a message is displayed that says that to run UNIX the "compaq configuration diskette" is required. On attempts to install linux the installer reads "kernel panic."

I have emailed HP/compaq about this but have not yet heard anything. Does anyone know what is going on here and is there any other way to solve the problem.

Any help would be appreciated.

exit3219 06-03-2005 03:44 AM

It is [very] possible that HP / Compaq has a deal with Micro$oft, thus making their PCs unable to use Linux / Unix. You probably son't ever get a response from them.
What kernel panic EXACTLY does the system throw at you?

dominedi 06-03-2005 05:40 AM

Quote:

It is [very] possible that HP / Compaq has a deal with Micro$oft, thus making their PCs unable to use Linux / Unix.
Imho this is just bullshit, or they will not ask for :

Quote:

At start-up the computers a message is displayed that says that to run UNIX the "compaq configuration diskette" is required
It would be nice if danieljames will provide us more information about this compaq pc, what model, what os was on it ? bios/setup utility is on the hd or not ? the hd is the original one or another one ?

Quote:

You probably son't ever get a response from them.
More probably they will answer him that the only support they give is for the original os they provide.

tw001_tw 06-03-2005 10:48 AM

Just a wild guess, but some of the older compaqs did have disk you needed -
'setup/configuration' & 'diagnostics'. Maybe if danieljames aquired these disks
from the compaq website, and tried to follow the instructions of what the system
is trying to say, it would work. I do remember seeing error messages refering to
UNIX drives when a HDD was changed in the system.

Thats not to say this will resolve the kernel panic, but it should resolve the post
test message refering to UNIX.

-tw

danieljames 06-05-2005 07:53 PM

I have a number of compaq machines and not all of them have this problem, for example I have three 450 mhz p2 and and two of them worked fine . I have been picking up cheap machines from ebay so that I can help out some fellow students and poor families get a working computer running linux. I am not an IT expert. as soon as exam week is over and my last assignment is in, I will post some more specific information about the machines this is happening to. but they are deskpro machines. and the kernal panic . . . the mandriva installer just said "kernal panic" . . . i didnt notice an expaination, although I did look. They do not have original hdd's. I bought pieces and have been putting them together i n my few spare moments.

Thankyou very much for your responce and interest into my problem and thankyou also for your patience with me in this vey busy time.

danieljames 06-05-2005 07:56 PM

also, they all run windows fine. this was the orignal os. I am not going to let the machines go out with pirated windows though.

PTrenholme 06-05-2005 08:19 PM

A quick google produced this link and I suspect that it, or something similar, is what you want. (There may, of course, be an AU site closer to you.)

Good luck, you goal is laudable. :)

dominedi 06-06-2005 03:28 AM

yes probably he nedd a softpaq of this kind, but he must be carefull using only the specific for the pc
he has

broderic 06-29-2005 09:45 AM

Dear Daniel James, I would like to hear from You haw far You got solving the problem with Linux on Compaq Deskpro.I have a piece of Compaq Deskpro EN and being not able to install RedHat any version on it neither in grafical nor in text mode - the process of installation breaks down at random point of installing the packets.Also this happens with Fedora.I gave up not knowing the issue of the problem.Do You have an idea what should be done - I have not opportunities to by other computer and I don`t appreciate putting pirate OS on the machine.
I am newbie also with Linux.
It is 333MHz P2 with MMX CPU machine.Old one.

J.W. 06-29-2005 01:25 PM

Welcome to LQ, broderic. When the installation stops, what system error message is being displayed? I will take a guess and ask if the problem could be that the disk drive you're using is too small. What size is it, and how is it partitioned? -- J.W.

danieljames 12-19-2005 04:06 PM

Just to let you know how it went. The problem is definitely a bios configuration issue as I gave Compaq a ring and found that it was a setting for certain corporate machines sold under particular licences. Installation would not even start.
Coming back to this after some time I found something a little interesting. I had more distros at my disposal having been a few Linux mags richer and tried a bunch of them. Some would would work, well more specifically, SuSE would.


I just worked out how to find these old threads, I searched for it a while ago and couldnt find it. Thanks for having helped I got really caught up with study and couldnt get back to the project.


All times are GMT -5. The time now is 12:40 PM.