LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-17-2003, 11:51 AM   #1
Spooky
Member
 
Registered: Dec 2002
Location: Portugal
Distribution: Fedora Core 5
Posts: 82

Rep: Reputation: 15
Compaq Presario 920 & Linux


Does anyone have instaled yet any distro sucessefuly into this laptop? Redhat 9.0 Mandrake 9.1? I have instaled parcialy sucessefuly the Mandrake 9.0 but this new one that suposebly would work just fine does not even let me start the install process ! Does anyone have experienced any install with M9.1 in this Laptop? Any sugestions?

Sp0okY OuT
 
Old 04-21-2003, 06:28 PM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 72
What problems are you having during installation? The biggest issue with the recent-ish Compaqs is their use of Trident Cyber(blah) video cards that weren't supported well in X-windows until 4.2.1 and 4.3.0, which means: Mandrake 9.0 and 9.1 respectively. Got a laundry list of its innards:

Also might want to check:

www.linux-laptop.net

Cheers,

Finegan
 
Old 04-22-2003, 09:54 AM   #3
Spooky
Member
 
Registered: Dec 2002
Location: Portugal
Distribution: Fedora Core 5
Posts: 82

Original Poster
Rep: Reputation: 15
Here's what i found about my problem ...

Quote:
"Upon booting the install CD, if you choose the default boot command linux, then the system will get to the beginning of Anaconda before freezing just after PCMCIA detection. This is due to a bug in the kernel related to the ALI southbridge. To continue the installation, at the prompt instead type linux pci=off and press enter. Installation should continue normally. Make sure you choose a text mode login, for xfree86 will not work without some tweaking "
some more info... (about Redhat 8.0)
http://www.wsu.edu/~ice124/

i'll report back when i have some more info ... if anyone has this kind of laptop and tryed Mand 8.1 or other distro please report back to me ...
 
Old 04-23-2003, 04:32 AM   #4
Spooky
Member
 
Registered: Dec 2002
Location: Portugal
Distribution: Fedora Core 5
Posts: 82

Original Poster
Rep: Reputation: 15
My Mandrake is working use the commands when you press f1 at the start of the installation process and type "linux noauto nomce" and it will work fine with sound and usb ... the special keys and the power tools have to be installed... with a patch...

Spooky OuT !
 
Old 10-06-2003, 10:32 AM   #5
rimar
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
hi! I have a compaq presario 920 and I can't install neither red hat 9 or mandrake 9.1

I already tried the option "linux noauto nomce", but after configure the mouse it says that had a hardware problem and stop installing. Can you help me please
 
Old 10-06-2003, 10:52 PM   #6
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 72
I'm poking around some pages on 900 series Compaqs and it looks like they have a 100% ACPI bios that has real issues with kernels that have no ACPI, also there's going to be issues with the ATI card. I would normally ask for an /sbin/lspci listing with these, but let's make certain we're talking the same machine here. What's the Vid card, chip, sound, and drive type?

Cheers,

Finegan
 
Old 10-07-2003, 03:49 AM   #7
rimar
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
Hi!

Technical Specs:
Compaq Presario 920EA
AMD Mobile Athlon XP 2000+
256 Mb RAM
30 Gb HD
ATI Mobility Radeon U1/IGP320M



I get the follow message during the installation:
"Can't find device for filesystems", but it's before the partitions.

Please help me
 
Old 06-23-2004, 04:53 AM   #8
Spooky
Member
 
Registered: Dec 2002
Location: Portugal
Distribution: Fedora Core 5
Posts: 82

Original Poster
Rep: Reputation: 15
It got me same problem with Mandrake 10 install and it was solved by not selecting any mouse device ... don't ask way but if u select one ... or not other than Universial driver it gives me that error... i can't install the mouse after that ... it doesn't work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Install on a Compaq Presario too_many_people Linux - Hardware 6 08-13-2004 12:10 AM
Linux on my Compaq Presario SR1103 soupatech Linux - Hardware 5 08-04-2004 08:47 AM
Linux on a Compaq Presario 1503AP iaac Linux - Laptop and Netbook 4 07-12-2004 05:32 AM
Linux on Compaq presario 1711T jaina2 Linux - Newbie 2 07-23-2003 12:17 AM
Linux on a Compaq presario ? jamaso Linux - Hardware 7 08-25-2002 12:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration