LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   compaq a900, redhat printtool, lpd, lexmark 7000 driver (https://www.linuxquestions.org/questions/linux-hardware-18/compaq-a900-redhat-printtool-lpd-lexmark-7000-driver-254199/)

whansard 11-12-2004 08:21 PM

compaq a900, redhat printtool, lpd, lexmark 7000 driver
 
I'm having to type all this crap over cause the computer froze hard when i had finished the first time. i've already spent 10 hours on this. i couldn't possible type in half the stuff i've tried, the versions of ghostscript and cups and apsfilter. anyway the linux version is currently redhat 6.2, havily modified, ghostscript 5.50, with lpd andthe lexmark printer driver for 7000 with redhats printtool. it has been working for printing black and white with tis combination for over a year. last nighgt i decided to put in the time to get it to print in color also. this compaq a900 is a multi purpose machine but prints with these drivers. i installed cpus and a few versions of ghostscripts and apsfilter among other things, and now i can't print anything. printtool hangs when it tries to print, and the system is crashing and programs are crashing like mozilla and wine programs.
i have given up and started trying to restore the system to what it was with a month old backup, but apparently i'm missing some things, and don't know where all the files involved with printing are. i've restored /etc/rc.d/init.d/ directory, the entire /var directory, /etc/printcap, /usr/lib/rhs/rhs-printfilters/ and even /usr/sbin/ i'm still getting the same crap.
what other places have i missed for printer configuration files. the devices appear the same too. i dont want to do a full restore, but i'm getting close. thanks.

more info: i am able to chroot into my full backup and printtool works, and i can print a test page with printtool if i start lpd. i booted gentoo and loaded up my messed up redhat and the month old one. when i chroot into each and try to print with printtool, the mess up one says" lpr: error-unable to print : client error not found ". in the working one, the error is " error printing test page lp error reason : lpr: connect: no such file or directory. jobs qued, but cannot start daemon.
if i run lpd in the second one, the test page will print. if i start lpd in the first one, printtool will hang.

whansard 11-13-2004 06:29 AM

it was either lpr lprm or lpq. i restored the old versions of them when i noticed there were new ones, and printtool started working.

i'm still fighting this bastard. i couldn't print under mozilla, and dvdshrink under wine is taking a few minutes to start. i've been messing with it, and it now it appears i can print when not online, but when online, mozilla will not print. at least i thought it wouldn't, but i left it for a while and after a few minutes, the print dialog would come up. i clicked print, and after a few more minutes, it started printing and mozilla became responsive again. i'm guessing it's trying to look up the printer name on the network? i don't know where to put it. it didn't need this before, but i've upgraded the lpr package. anybody know what to do?

whansard 11-14-2004 08:33 PM

I messed with this all day long. at last i used the old method of putting a backup on a different hard drive, and symlinking different directories in and testing it. like i would mv /usr to /us and ln -s /mnt/hde5/usr /usr then startx and test it. it was in /usr/lib. stinking libcups* stuff. sorry crap. if that crappy cups had an uninstall i would have had this done 2 days ago. i tried to make uninstall, but it didn't have that function. first the utilities wouldn't let me print at all, then i got rid of them and i could print with some programs, and others would mess up when i was online. i deleted those cups libraries, and everything went back to fine. thanks cups!


All times are GMT -5. The time now is 12:10 AM.