LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   cinfiguring Nvidia graphics cards (https://www.linuxquestions.org/questions/linux-hardware-18/cinfiguring-nvidia-graphics-cards-365788/)

daedalusonlinux 09-22-2005 12:44 AM

cinfiguring Nvidia graphics cards
 
Ok, so I've got hardware acceleration and every thing works good. What I want to know is how to configure my graphics card. I'm running SuSE 10.0 RC1 with an Nvidia 6600 GT card and the lastest linux drivers installed by Yast2. When I go into the sax2 applet and click on the "options" button for my card a list of various settings come up but I don't know what each one does or what the input value needs to be. I've searched this site and I have also searched a9.com but to no avail. Thanks for any help.

Oliv' 09-22-2005 02:52 AM

ftp://download.nvidia.com/XFree86/Li...676/README.txt

daedalusonlinux 11-20-2005 08:23 PM

Ok, so I have gone through the readme and set-up x.org but I still dont get an image on my TV. What I am doing wrong? Here is my config file.

# /.../
# SaX generated X11 config file
# Created on: 2005-11-20T18:02:26-0700.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "logiitc"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "8"
Option "Device" "/dev/input/mice"
Option "Name" "MX 900 Bluetooth"
Option "Protocol" "ExplorerPS/2"
Option "Vendor" "Logitech"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 340 270
HorizSync 30-81
Identifier "Monitor[0]"
ModelName "SAMSUNG 173V/172V"
Option "DPMS"
VendorName "SAMSUNG"
VertRefresh 56-76
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 136.57 1280 1288 1424 1712 1024 1041 1044 1068
Modeline "1280x960" 128.13 1280 1368 1504 1728 960 961 964 1002
Modeline "1280x960" 109.13 1280 1360 1496 1712 960 961 964 996
Modeline "1280x800" 105.78 1280 1360 1496 1712 800 801 804 835
Modeline "1280x800" 90.09 1280 1352 1488 1696 800 801 804 830
Modeline "1152x864" 103.59 1152 1224 1352 1552 864 865 868 902
Modeline "1152x864" 88.18 1152 1224 1344 1536 864 865 868 897
Modeline "1280x768" 101.60 1280 1360 1496 1712 768 769 772 802
Modeline "1280x768" 85.69 1280 1344 1480 1680 768 769 772 797
Modeline "1024x768" 80.71 1024 1080 1192 1360 768 769 772 802
Modeline "1024x768" 68.55 1024 1080 1184 1344 768 769 772 797
Modeline "800x600" 48.18 800 840 920 1040 600 601 604 626
Modeline "800x600" 40.83 800 832 912 1024 600 601 604 623
Modeline "768x576" 44.83 768 808 888 1008 576 577 580 601
Modeline "768x576" 37.97 768 800 880 992 576 577 580 598
Modeline "640x480" 30.25 640 664 728 816 480 481 484 501
Modeline "640x480" 25.55 640 656 720 800 480 481 484 499
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce 6600/GeForce 6600 GT"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "UseEdidFreqs"
Option "NoLogo"
Option "RenderAccel"
Option "HWcursor"
Option "CursorShadow"
Option "TwinView"
Option "DigitalVibrance" "85"
Option "NvAGP" "3"
#Option "NvAGP" "3"
#Option "NvAGP" "1"
Option "VertRefresh" "CRT: 60-75; TV: 60"
Option "MetaModes" "1280x1024 +0+0, 640x480 +1280+1024"
Option "TVStandard" "NTSC-M"
Option "HorizSync" "CRT-0: 30-81; TV-0: 30-50"
Option "ConnectedMonitor" "CRT, TV"
Option "TVOutFormat" "SVIDEO"
#Option "NvAGP" "2"
#Option "NvAGP" "0"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

daedalusonlinux 11-26-2005 07:47 PM

OK, so I got the TV-out working but now if I have a window open and try to open another it goes to my TV rather then my monitor where I want to open. Also, when playing video on my TV in fullscreen mode, rather than player at the resolution I set for my TV it plays at my monitor's resolution. Anybody have any thoughts on these two problems? Thanks.

slackmagic 12-02-2005 03:12 AM

Code:

Option "ConnectedMonitor" "CRT, TV"
The order of which display device you name first is important here. Make sure you have CRT (your main display) first, and then TV (set as second display).

The problem with playing a movie on TV and it actually playing it with the monitor's resolution is because the TV will never be able to handle what your monitor could (I could be wrong here but at least I believe to be correct with this :P). For example my TV only can go as high as 1024x768 whereas my current 19" CRT monitor works just fine with 1600x1200.

You can either play a movie by moving and resizing "mplayer's output" around so it fits rigth on your TV's screen (including removing the titlebar which I'm not going to explain how to get rid of here because it depends also on what window manager or DE you're using) OR you can play around with

mplayer -vo help

and try different video outputs


I for example use

Code:

mplayer -vo svga filename.fileextention
and it full screens my movies right on my CRT and TV

if I want to play a movie on both display devices


Hope this helps!


All times are GMT -5. The time now is 11:35 AM.