LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Choppy mouse movement with xorg 6.7.0-11 (https://www.linuxquestions.org/questions/linux-hardware-18/choppy-mouse-movement-with-xorg-6-7-0-11-a-276401/)

tommyr1216 01-11-2005 01:17 AM

Choppy mouse movement with xorg 6.7.0-11
 
The movement of my mouse cursor is very eratic. For example, if I try to move the cursor straight across the screen, the mouse will go straight for a little bit, then dive down a little, and then come back up to the original line. It moves kinda like one of those heart monitors they have in the hospital. After some research, I disabled HWCursor in my xorg.conf file, which made the problem less severe, but didn't cure it entirely. I haven't been able to find any other information on this problem or this mouse. I dual-boot with Windows 2000 on this system, and the mouse is perfectly smooth there.

logitech mx1000 mouse
Fedora Core 2
Kernel 2.6.9-1.6
xorg-x11 6.7.0-11
kde 3.2.2-6
geforce 4 ti 4600 using nvidia linux drivers v1.0 build 6111

***Relevant sections from xorg.conf***
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "6 7"
Option "Emulate3Buttons" "no"
Option "Buttons" "12"
EndSection
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 0
Option "HWCursor" "false"
Option "NoLogo" "yes"
EndSection

Any help is greatly appreciated

ganja_guru 01-11-2005 02:16 AM

try adding
Option "Resolution" "600"
Option "Samplerate" "1000"


thats what worked for me on a 1600x1200 desktop...play around with those settings and it shuould help(specifically sample rate)

tommyr1216 01-11-2005 12:37 PM

I've played around with "Resolution" and "Samplerate" for a few hours now. Adjusting the sample rate does seem to affect the problem, but I can't seem to make an improvement. Dropping the sample rate makes the problem worse, however, increasing it doesn't make it better. I've tried a bunch of sample rates, from 150 to 3000.

Does X perhaps offer 'mouse smoothing' like some 3D games do? I don't usually like this, but I'd be willing to try it to eliminate these cursor jumps.

ganja_guru 01-11-2005 10:51 PM

i read somewhere that this might have to do with hdparm ...can u post the output of

hdparm -i /dev/hda (assuming hda is ure primary harddisk)

tommyr1216 01-16-2005 07:59 PM

I have two hard disks, hda and hdc. My root partition is on a RAID-0 array between them.
This is the output from hdparm.
_________________________________________________________________
/dev/hda:

Model=Maxtor 5T060H6, FwRev=TAH71DP0, SerialNo=T6HFACHC
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=120103200
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 0:

* signifies the current active mode
__________________________________________________________________
/dev/hdc:

Model=SAMSUNG SP1203N, FwRev=TL100-24, SerialNo=S00QJ10X767386
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=34902, SectSize=554, ECCbytes=4
BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=234493056
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=no WriteCache=enabled
Drive conforms to: (null):

* signifies the current active mode

ganja_guru 01-23-2005 12:48 AM

yup, dma is disabled...just to confirm, see the output of hdparm /dev/hda (and hdc)

if dma is off, do this ....

hdparm -d 1 /dev/hda
hdparm -c 3 /dev/hda (if this isnt supportd do a 'c 2')
hdparm -X 66 /dev/hda

repeat the same for the other drive ...

do a comparison of the test results of 'hdparm -tT /dev/hda' before and after using hese settings..

note: these settings are not permanent, just copy paste them to /etc/rc.d/rc.local or whatever..


All times are GMT -5. The time now is 08:04 PM.