-   Linux - Hardware (
-   -   CentOS 5 Kmix and skype (

skoda 07-09-2013 11:49 AM

CentOS 5 Kmix and skype

i am banging my head now for hours.
i can't get my microphone to work with skyp.
i use skype in wndows7 having no issues.
pls help.

kmix > input tab, i have selected all 4 options (LEDs are in Bright pink color) and in kmix > output > i have enabled all controls (bright green) and put every to 100%. but in skype call testing, i can only here that lady is talking, after recording nothing. some time the recording is noisi, not clear at all.

pls help.

gradinaruvasile 07-15-2013 05:28 PM

Have you actually tried to record anything with any other program? Usually Skype isnt the problem here.
The lowest level test is:


arecord | aplay
or, for better quality:


arecord -f cd | aplay -f cd
This essentially pipes back the recording into the output device. Stop with ctrl-c. If this works, you have the problem upper in the food chain. Which unfortunately i dont know exactly, i am not that familiar with KDE's way of doing things.
In any case, Skype uses Pulse Audio if available. If you have it installed, you should install pavucontrol and see if the mic works in it.

If this doesnt work, you have to work with alsamixer (in terminal). That is the lowest level mixer you have - you can set mic levels etc there (basic rule is to disable mics in the playback tab, then go to the record tab and see what options you have there). It works real time so you can have it open while you do the arecord/aplay test.

brunobbn 07-15-2013 06:18 PM

If you plugged the cable behind the pc, go to the kmix, add the 'Rear Mic' and 'Capture' channel, probally your 'Rear Mic' will be muted, so unmute it and try a call.

skoda 07-24-2013 12:49 PM

2 Attachment(s)
Hai guys,

thanks for your valuable suggestions and finally got sorted.
skype works charm.
the mixer setups has been shown in the 2 attachment.

All times are GMT -5. The time now is 02:00 PM.