-   Linux - Hardware (
-   -   CentOS 5.5 and GPT (

fantasygoat 04-05-2011 05:12 PM

CentOS 5.5 and GPT
I'm trying to set up a Dell R410 with a PERC H700 RAID controller and a 6TB RAID array, and I'm getting the "boot partition is on a disk using GPT partitioning scheme but this machine cannot boot using GPT" error.

I've tried using the dd technique to zero out the partition but it hasn't worked. Neither has using parted or fdisk - everytime I do it and return to the install screen, it says it's a GPT partition.

Has anyone managed to get this to work?

tredegar 04-05-2011 06:09 PM

Big disks (generally > 1TB) need special tools to deal with GPT.

Here is a link to get you started.

AFAIK only grub2 can boot from GPT disks.

fantasygoat 04-06-2011 09:10 AM

I don't want it to be GPT. Most of the guides recommend using dd to clear the partition info and then proceeding, but that hasn't worked for me so I was hoping someone had some other suggestions.

ongte 04-07-2011 10:12 PM

The dd thing nonsense, the bottom line is > 2TB GPT hard drives are not supported as a bootable device for RHEL/CentOS. The Anaconda installer is also unable to deal with > 2TB drives/arrays.

Once a disk goes over 2TB. The traditional MBR partition table does not work anymore. You MUST use GPT. Although CentOS will not boot off a GPT disk, it is able to use it as a storage partition.

There are some workarounds, but they don't work for everyone. So your best options is to make a smaller (< 2TB) array to install the OS into, then create the larger array & mount it into a directory once the OS is working.

Skaperen 04-08-2011 11:40 AM

You must use GPT to make use of more than 2TB (sometimes certain hacks can get this up to 4TB but standard tools won't do it and no one partition would be larger than 2TB).

If the BIOS is trying to interpret the partition table for some reason (it should not need to, but some machines do have this, for better or for worse), you may be able to fake it with a hybrid partition table and a reserved small boot partition at the low sector locations. If the BIOS is looking at the MBR table for the GPT reservation, the trick could work. If the BIOS is looking at sector 1 for a GPT header, it won't work.

All times are GMT -5. The time now is 03:53 PM.