-   Linux - Hardware (
-   -   CenDyne external 56k modem (

z-lite 04-23-2004 08:42 AM

CenDyne external 56k modem

I'm running Gentoo linux with the 2.4.25 vanilla kernel and am using my linux box to be my gateway for my home network. I have a CenDyne external serial modem (says it's 56k, chipset is CX06827-11) but when I use wvdial to dial out to my ISP, it connects at 28k speed and this is too slow for my gaming needs (56k is too, but I can still do some damage).

I've searched google and this forum but have found no response for modem init strings to have my modem connect faster. Do any of you use this modem and can post your modem init strings to connect at speeds faster than 28k.

njbrain 04-23-2004 10:03 AM

Did you check your wvdial settings?

z-lite 04-23-2004 10:58 AM


[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = AT+MS=v90
#ATQ0 X4 V1 E1 S202=32 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem

That's my wvdial settings, with Init2 being the initiation string to tell the modem how to respond to the ISP (a guess). Conexant's site says that using +MS=v90 will tell the modem enable v.90 but I still connect at 28k, and I know I can go up to 49k when I had Win2k3 installed (not with the same modem though).

z-lite 04-24-2004 01:11 AM


z-lite 04-24-2004 03:45 PM

Can someone please post their modem init strings? I know some of you guys use this modem because of the threads that I've searched.

penquissciguy 04-28-2004 06:41 PM

Here's my autodetected wvdial.conf for my CenDyne.

[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem


DaneM 05-30-2004 02:16 AM

Hello, everybody.

I'm having exactly the same problem. I've contacted the people at Linuxant and they seem to be stumped. Currently I'm using MDK 10 Official, kernel 2.6.6.

I did, however manage to get it working with kernel 2.6.3-7 using the init strings they gave me the first time this happened. Here they are: (The second one is what fixed it for me.)

(string #1) AT &F W1 +ER=1; +DR=1; +MS=V90,0

(string #2) AT &F W1 +ER=1; +DR=1; +MS=V90,1

(string #3) AT &F W1 +ER=1; +DR=1; +MS=V34,0

(string #4) AT &F W1 +ER=1; +DR=1; +MS=V34,1

The reason they gave me all these alternate strings is because (based on the output files I sent them) they determined that my modem was running in v.34 mode instead of v.90. I hope this helps!

PLEASE let me know if you find another solution!



rhb327 06-29-2004 07:21 AM


The fourth string works for me. I now get stable connects at 28800 or 31200 actual connection speed. Thanks for the information.

All times are GMT -5. The time now is 08:02 PM.