-   Linux - Hardware (
-   -   CDRom works under /Root, not under non-/root (

junger 07-24-2005 05:37 PM

CDRom works under /Root, not under non-/root
Hey, newbie to Linux here!
Anyway.... I am working with fedora core 3, linux kernel 2.6.9-1.667 on a Pentium 2 500mhz computer, with a S3 Savage4 AGP card, Soundblaster AWE 32, ~300MB ram, 13GB HDD (Linux) dualbooting with 4GB HDD (Windows 98), 2 cdroms (both non-writers).
I have not been able to update any aspect of Linux, as I am not able to hook up a modem yet (this is another problem I need help on...later, though. not as important)
When I am under the /root user, I can play audio cd's no problem. under a different user, though... using just the regular cdplayer that comes with fc3, I get "drive error". I've tried other programs as well. No good. Under my Windows installation, cdrom works fine.

junme 07-24-2005 10:02 PM

seems like you need to allow users to acess the cdrom
an easy way if u use kde is use kuser as root look at the users groups and add them to group cdrom
not sure how FC is set up but generaly there is a file /etc/group which stores this info
hope this helps :-)

junger 07-25-2005 01:09 AM

Um... yeah. I'm a newbie, so you might have to walk me through this one...
do you mean log on as "root"?
there is no entry under "etc/groups" that says "cdrom"
I can read data cd's no problem under either user acct, but only "/root" can play audio cds.
I could have a "helper problem" as well, that might guide you to the correct solution. I have a USB flash drive (lexar jumpdrive secure) and under "/root" I can access this no problem, it shows on the desktop. But under "jason" (that's my main login) i get the error:
"Unable to mount the selected volume
mount: only root can mount /dev/sda1 on /mnt/public_a"
this installation of FC3 is only a week old, so one would think that there should be no errors in the subsystem. But, I already had to deal with a login issue, where the system tried to look up some internet thing reguarding "localhost.localdomain"
Ach.... this is getting annoying. Then again, linux was (is) written by practically millions of people!:D

junger 07-25-2005 02:49 AM

oh... actually... i figured it out. but not fully in the way you told me.
For the cdroms... I had to add "jason" to the "disk" group. Do you know if there will be any problems from that?
And for the USB drive... this was weird. I thought that if I couldn't use "jason" normally to access the flash drive, what if I ran "mount dev/sda1 mnt/public_a" under terminal. Well, I tried that, and got some error saying something like "only root can do that". So I thought what if I switched users, without switching users? Staying logged under "jason", I ran "su root" under terminal, switched to root that way, and reran the mount command. IT WORKED, but I think there should have been a more straightforward way to do this. IE, not have to go through that procedure for each user.

Nylex 07-25-2005 02:52 AM

Edit: never mind now!

Walman 07-25-2005 11:30 AM


Root can only mount files by default and unless you specify that other user can do it , you are stuck to that law . Erlier , Member junme supplied you with the answer .
What environment are you running ? kde , gnome , other ??

junger 07-25-2005 08:26 PM

I use gnome, but KDE is installed also.

All times are GMT -5. The time now is 08:49 PM.