-   Linux - Hardware (
-   -   cdrecord doesn't work, scsi emulation on? (

tsphan 02-01-2005 10:52 PM

cdrecord doesn't work, scsi emulation on?
Sorry i have to bring this back up again, but appearently, i tried burning something and it didn't work.

My cdrom burner isn't being detected by cdrecord, but cdrdao is.

I get this when i typed "cdrecord -scanbus -dev=/dev/hda":
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: '/dev/hda'
devname: '/dev/hda'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
cdrecord: Invalid argument. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

It does pretty much the same thing without -dev=/dev/hda

My cd burner is on primary master
SCSI-Emulation I believe is on
My kernal is 2.4.26

K3b and other frontends don't work
cdrdao is detecting it as /dev/sr0 though, so i dunno what the problem could be.

Oliv' 02-02-2005 08:28 AM


well what about: cdrecord -scanbus (without dev option) and which modules (or kernel options) have you for your scsi drive (see this link (section2) )


foo_bar_foo 02-02-2005 12:54 PM

cd dev
ln -s sr0 cdrom
ln -s sg0 cdrecorder

tsphan 02-02-2005 06:39 PM

It does the same thing if i do cdrecord -scanbus.

I think it's because when my brother first compiled my kernel for me, he didn't include SCSI Generic Support. I'll recompile my kernel and place it as a module, i need to recompile it anyways. I hope this works

tsphan 02-02-2005 09:05 PM

Alright! I just fixed it. I recompiled my kernel with SCSI Generic support modulized, now it works. Thanks everyone, thanks Linuxquestions, you rule!!!

All times are GMT -5. The time now is 07:37 PM.