LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-15-2003, 06:31 PM   #1
brianthew
LQ Newbie
 
Registered: Aug 2003
Location: USA
Distribution: Mandrake 9.1
Posts: 6

Rep: Reputation: 0
CD-ROM death, Mandrake 9.1


Hello everyone.

I'm a fairly new user of Mandrake 9.1, running KDE.

Yesterday, with no warning, both my CD drives suddenly were unable to read CDs. Even stranger, I can still burn CDs, just not read them. Now, I know the drives themselves are still good; Windows XP handles them just as before.

The CD-ROMs stopped working in the middle of opening a file from a CD; I opened the CD window, double click on file, and then it sat, spun a little, then got the "Cannot enter /mnt/cdrom" error. No hardware, driver, etc changes have taken place. Now, when I place a CD in the drive, it will spin up, stall a little, and spin down, still can't read them. I've rebooted a whole bunch, disconnected and reconnected hardware between boots, no avail.

Ideas??

Thanks in advance.
 
Old 08-15-2003, 07:07 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Try going into /etc and post us your "fstab" file. Sounds like they are wrongly mounted
 
Old 08-15-2003, 07:45 PM   #3
brianthew
LQ Newbie
 
Registered: Aug 2003
Location: USA
Distribution: Mandrake 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
Alrighty:

/dev/hdb6 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/win_c ntfs iocharset=iso8859-1,ro,umask=0 0 0
/dev/hdb5 /mnt/win_c2 ntfs iocharset=iso8859-1,ro,umask=0 0 0
/dev/hda5 /mnt/win_d ntfs iocharset=iso8859-1,ro,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb2 swap swap defaults 0 0
 
Old 08-15-2003, 07:49 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Curious Mine has:

Code:
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660 noauto,owner,kudzu,ro 0 0
Have you tried to remove that "none" from /mnt/cdrom ? Please note: I've no idea what I'm doing I've never seen none before in there and our fstab could not look more different

Last edited by Mega Man X; 08-15-2003 at 07:50 PM.
 
Old 08-15-2003, 07:52 PM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Or maybe add my line to yours. Or maybe I should wait somebody with more experience to help us here
 
Old 08-15-2003, 07:59 PM   #6
brianthew
LQ Newbie
 
Registered: Aug 2003
Location: USA
Distribution: Mandrake 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
heh...I think the "none" is for "no disk in drive." When I remove the "none" it opens all the drives up for viewing (as opposed to thier normally locked status). Still no dice.

Also, it seems like the problem affects all removable media, the floppy drive as well.

Heh...although using my other box's CD-drive and floppy drive over a Samba share is awfully amusing....

Last edited by brianthew; 08-15-2003 at 08:01 PM.
 
Old 08-15-2003, 08:03 PM   #7
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Can you mount the device manually?

mount -t iso9660 /dev/scd0 /mnt/cdrom2


I have seen fstab files, but none quite like this, although I did search and this appears to be another format, and from what I've read don't remove "none".

mine is

/dev/cdrw /mnt/cdrw auto ro,user,noauto,exec 0 0
 
Old 08-15-2003, 08:12 PM   #8
brianthew
LQ Newbie
 
Registered: Aug 2003
Location: USA
Distribution: Mandrake 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
w00t.

Manually mounting works. Will this stay between boots, or do I gotta make a shell script or something (pardon the n00bness)?
 
Old 08-15-2003, 08:31 PM   #9
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
No, this just means theirs nothing wrong with the drivers or anything, we just have to figure out why the fstab entry doesn't work.

Try
mount /mnt/cdrom2

if that works then theres something wrong with the links in KDE.

If not try replacing fs=auto with fs=iso9660 and do it again.

if that doesn't work try changing the iocharset too iocharset=iso8859-15, and removing codepage=850 completly.

Don't forget no reboots needed.
 
Old 08-15-2003, 08:34 PM   #10
leiavoia
Member
 
Registered: Mar 2002
Distribution: Debian Testing & Kubuntu
Posts: 72

Rep: Reputation: 15
if you use Konquerer or somesuch file manager, i find that i often have to close the app, then restart it to "free" the CD drive. that is not always true of all apps but seems to be Konquerer in particular. Mandrake uses "supermount" to mount drives when needed, except it is still getting bugs worked out of it methinks.
 
Old 08-16-2003, 12:09 AM   #11
brianthew
LQ Newbie
 
Registered: Aug 2003
Location: USA
Distribution: Mandrake 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
Interestingly enough, I did a manual mount on each of the drives, rebooted, and things seem to be fine now. Hmm, oh well. At least it works, even if the cause is kinda mysterious.
 
Old 08-16-2003, 12:36 AM   #12
leiavoia
Member
 
Registered: Mar 2002
Distribution: Debian Testing & Kubuntu
Posts: 72

Rep: Reputation: 15
rebooting should always reset mounted status. so if you ever get drive lockup or "device is busy" jazz, that's one way to do it (not the best way, but the easiest to do for sure)
 
Old 08-16-2003, 01:03 AM   #13
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Lightbulb Here's more info

I use Mandrake 9.1 to. Here's my fstab:
/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,user,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,user,iocharset=iso8859-1,sync,codepage=850,umask=0,users 0 0
/dev/hdb1 /mnt/windows vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda6 /usr ext3 defaults 1 2
/dev/hda5 swap swap defaults 0 0
/dev/scsi/host0/bus0/target0/lun0/cd /mnt/cdrecorder auto ro,noauto,user,exec 0 0

NO, I don't have windoze. It's just for data backup.
I have had the same problem and I got used to closing Konqueror when changing CD's etc. Supermount is a good idea but it needs a little more work.

Compare files and see if yours is the same.

 
Old 08-16-2003, 06:39 AM   #14
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
There is nothing wrong with your /etc/fstab file; it is standard Mandrake 9.1 configuration for a CD-ROM (hdc) and a CD Burner (scd0). Supermount needs 'none' instead of the device name; that's just a Supermount peculiarity. The supermount readme from Sourceforge.net carries the following comment about the supermount entry in /etc/fstab:
Quote:
You mount a supermount filesystem with
the normal mount command, using the syntax

mount -t supermount -o <superfs-options>,--,<subfs-options> none <mpt>

or by adding correpsonding line to /etc/fstab

none <mpt> supermount <superfs-options>,--,<subfs-options> 0 0

where

<superfs-options> are the options you want to pass to supermount
itself. These are described below.

<subfs-options> are the options you want supermount to pass to the
dismountable filesystem underneath.

<mpt> is the mount point where you want your removable media to be
mounted.

WARNING: in the above description `none' is literal word. While device
is ignored by supermount itself, using real files in this place (real
device name or mount point directory name) is known to cause problems.

Some programs - fuser is one of them - will try to descend into filesystem
if dev can be statted, thus making supermount to attempt to access media.
This is annoying at best - in the worst case it can take very long time
during startup or shutdown.
It's more likely your problem is caused by supermount not being fully developed yet, and Konqueror having troubles with that. If you close Konqueror and re-start it, you might be able to list the CD-ROM's files again.

If you're still having problems with reading your CD-ROMs, open Mandrake Control Centre->Mount Points->Set where your DVD-ROM drive is mounted, and set the configuration again. When you exit, the mount point settings (including /etc/fstab) will be refreshed.
 
Old 08-16-2003, 11:58 AM   #15
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Question What model

I bought a CD R/W once and tried the Mandrake control panel and everything else but it didn't work. I finally swapped for another brand. The one I had was a SW248. I think it was Samsung. I was told that any IDE drive would work. After getting tired of messing with it I took it back to the store and swapped for a LG brand. It recognized the change when I booted and it worked ever since.
I never did figure out why the other didn't work. I tried everything. You may want to try another brand from a friend and see how it works. I also had flakky problems with my floppy when the old CD R/W was in the puter.
BTW, I did burn a CD and access it a few times before it stopped. After it messed up though I never got it to work again. It could boot from it and worked fine in DOS but not in Linux.

Hope it's not like the one I had. That thing had me pulling out hair.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
White screen of death after restoring from backup.Mandrake leongoogs Linux - Newbie 1 04-09-2005 02:10 AM
Mandrake 10 nforce random crashing, drivers of death, and much uncoolness squishypickle Mandriva 2 06-03-2004 05:14 PM
Is Mandrake guilty about the death of my CDROM's? aguilarces Linux - Hardware 1 10-11-2003 11:31 PM
Is Mandrake guilty about the death of my CDROM's? aguilarces Linux - Hardware 1 10-11-2003 09:20 PM
Is Mandrake guilty about the death of my CDROM's? aguilarces Linux - Hardware 0 10-11-2003 08:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration