-   Linux - Hardware (
-   -   CD/DVD Burning starts OK, but fails to complete (different OSes/burning software) (

dkaplowitz 08-11-2009 09:34 AM

CD/DVD Burning starts OK, but fails to complete (different OSes/burning software)

It's been happening for a while, and on the last two versions of Ubuntu and in FC10. I've used Brasero, k3b, or growisofs from the cmd-line. While burning CD/DVD ISOs in particular, the burning process starts fine (writes data to the disk) but it never completes and the expected time left keeps growing seemingly infinitely. Killing the burn process leaves the CD locked and doesn't let me eject the CD.

My guess is that it's something with growisofs since that's the only thing that's the same all the time, or it's a hardware problem, but I'm pretty sure I've successfully burned other data CDs/DVDs okay recently with this drive. (It's a Plextor)

I can't find any log info, so troubleshooting has been spotty at best. Any suggestions on things to try/look at?



business_kid 08-11-2009 11:14 AM

OK.Try a test with mkisofs - it will write to disk. get 650MB worth and try that. letr's call it test.iso. You can mount test.iso with -o loop and check it. If that doesn't complete, check memory & disks with appropriate tools.

Then use cdrecord manually, start with cdrecord -scanbus. find your drive. You may have to make a symlink sg0 to point at your device.

In the command below, <your drive> will be three numbers, e.g. 1000,0,0
cdrecord -vvv dev=<your drive> speed=2 /path/to/test.iso

You should get piles of ugly debugging type stuff on a console while it tells you exactly why you shouldn't ever use linux, what it's guessing, doing, and getting right/wrong. The author is a berk(May I say that on a moderated forum?). Opotionally you can add '> debugfile 2>&1' to trap all this in a file

garydale 08-11-2009 11:45 AM

sounds like hardware
I'm assuming you're booting one or the other distros from a live CD. That pretty much precludes a software issue unless they were both running the same buggy version of growisofs. You may want to try a recent live CD if that is not the case, or try getting an updated version of growisofs from a Debian/Sid repository (under Ubuntu).

dkaplowitz 08-14-2009 07:47 AM

@BK, thanks for the reply. Using that method I burned an iso fine with no issues. It doesn't help me figure out what's going on with the other software, but maybe I'll just keep burning that way instead of using these crappy burning guis.



business_kid 08-15-2009 04:35 AM

I found k3b about the best of them - _If_ you have the dependencies. Burning that way normally, drop the -vvv. Maybe just use -v. You don't want to get nagged.

More importantly, this verifies your equipment. You should be able to use growisofs also for dvds. Try
ldd /path/to/growisofs |grep found

anything that shows up is a missing dependency.

lindsay_keir 09-02-2009 10:30 PM

I think the degeneration is caused by two things ...
Same problem; but things eventually degenerated until I had 100% failures. I think the degeneration was caused by two things ...
(1) the newer kernels.
(2) k3b's switch from cdrecord to woim(?).

Anyway, with 2 computers, both running Kubuntu Jaunty I ...
(1) Updated the USB DVD's driver from the vendor to a MS-Vista version (this is important). I think this brought the burner into line with the latest kernels - I ignore the kernels because I'm simple-minded and let ksplice-uptrack do it's patches (don't you?).
(2a) On PC1 I compiled cdrecord and pointed k3b to use cdrecord - and burning failed.
(2b) On PC2 I used the untouched latest k3b - and burning and verification was successful.

I've tried this 3 times so far. Each time the cdrecord version failed and the untouched k3b worked. After each falure I re-used the same DVD-RW for the successful run.
So, update those external device drivers!

Tags: k3b cdrecord dvd burning

All times are GMT -5. The time now is 05:10 AM.