-   Linux - Hardware (
-   -   CD-Burner Lockups in RedHat 9 (

CodeSplice 03-28-2004 08:45 PM

CD-Burner Lockups in RedHat 9
Hey guys (and gals)

This is kinda a hardware issue, and kinda a software issue... but the hardware half is more annoying than the software, I suppose, so that's why it's here.

I recently (well... about a month ago) got rid of RH8 and brought in RH9. Under 8, after correctly setting up the SCSI emulation for my CD-R drive, I had no problems at all burning CDs (both data and audio). But after the upgrade, I have yet to be able to successfully burn a CD.

Using cdrecord, I get no error messages, but the program exits after displaying that it had succesfully burned 0 of XXMB on Track 1... hence the software issue.

For the hardware part, the CD-R drive locks up... The red "burning" light stays lit, and I can hear the CD-R inside spinning rapidly. I press the eject button; nothing happens. I go to the Process Table and kill anything that could possibly be occupying the drive; still no luck. I finally halt the system, watching carefully as it OK's all of the tasks to perform upon system halt; CD drive still won't wake up. When it displays the final "System halted." message, the drive is still trying to do whatever it is that it is trying to do... Only when I fully power-off does the drive stop (and it takes a good 10 seconds to spin down). Power back on, and then I can eject the CD. I look at the underside of the disc, and can see that something was actually written, but when I try to mount it, I'm told that the media is corrupt. No duh.

Anyhoo, I've got some data that I need to put on CDs soon, so any help with this issue would be greatly appreciated.

Thanks guys!


CodeSplice 03-30-2004 07:09 PM

More info
Since the last post, I figured I might wanna give you folks some more information on the problem.

First, my /etc/fstab file:


LABEL=/                /                      ext3    defaults        1 1
LABEL=/boot            /boot                  ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
LABEL=/home            /home                  ext3    defaults        1 2
none                    /proc                  proc    defaults        0 0
none                    /dev/shm                tmpfs  defaults        0 0
LABEL=/tmp              /tmp                    ext3    defaults        1 2
LABEL=/var              /var                    ext3    defaults        1 2
/dev/hda6              swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy            auto    noauto,owner,kudzu 0 0
/dev/sdb1              /mnt/usb1              auto    user,noauto,umask=0 0 0
/dev/sda1              /mnt/usb2              auto    user,noauto,umask=0 0 0

And now, the output from cdrecord --scanbus:


[root@SplicedBox csplice]# cdrecord --scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.
75-RH '@(#)scsi-linux-sg.c        1.75 02/10/21 Copyright 1997 J. Schilling').
        0,0,0    0) 'LITE-ON ' 'LTR-52327S      ' 'QS04' Removable CD-ROM
        0,1,0    1) *
        0,2,0    2) *
        0,3,0    3) *
        0,4,0    4) *
        0,5,0    5) *
        0,6,0    6) *
        0,7,0    7) *

If anything else is needed, please ask! And... please help :)


CodeSplice 03-30-2004 10:17 PM

Problem solved!

I think I may have had the write speed set too high (that's the only thing I changed before doing a successful dummy burn and then two real burns). The drive is spec'ed to 52X32X52X, so I had set the write speed to 24X. Evidently, this was causing buffer problems (or something), so I clocked it back to 8X and it works like a charm.

Now... any suggestions on what I can do to make this drive achieve its potential 52X write speed? If not, that's cool... just... yeah.

Anyhoo, I'm done!

dopefish 03-31-2004 04:00 AM

Dunno if this would help but see if DMA is enabled
hdparm /dev/<burner device>

All times are GMT -5. The time now is 04:38 PM.