LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Can't start GUI after Kernel Update (https://www.linuxquestions.org/questions/linux-hardware-18/cant-start-gui-after-kernel-update-191994/)

Fe98 06-10-2004 01:09 PM

Can't start GUI after Kernel Update
 
I updated my RH9 using the Red Hat update thingie (I'm a real newbie at Linux so be kind please!) and now I can't start my GUI (is it called X?).

The problem occurred, I think, due to the fact I updated (before the kernel update) my video card drivers (i have a GeForce 4) using the nvidia update thingie.

Basically I think I have to rebuild the drivers for the new kernel. That works successfully yet I still can't start the GUI. The monitor appears as if it is switching modes yet I get an error saying the GUI couldn't start (something along those lines).

Any suggestions? Thanks.

geniarse 06-10-2004 01:16 PM

is the driver correctly configured in your XF86Config file, dirver should be nvidia. If the driver is nvidia try replacing with nv to get basic functionality (no hardware acceleration).
this is my device section from XF86Config, which works in slackware 9.1 kernel 2.6.5


Section "Device"
Identifier "NVIDIA Geforce4"
Driver "nvidia"
VideoRam 65536
Option "NoLogo" "true"
# Insert Clocks lines here if appropriate
EndSection

Fe98 06-10-2004 02:45 PM

I tried doing that but it didn't work (same problem as before). Any other sugggestions?

geniarse 06-10-2004 03:04 PM

maybe its your monitor try re-configuring Xfree by running xf86config setting lower monitor refresh rates. after booting to run level three by specifying init 3 in lilo

Fe98 06-11-2004 07:43 PM

Thanks, geniarse, but I was unable to run xf86config. The command is not there (can't remember the exact error message).

Basically on startup, it changes the screen mode from a text to a graphical one (which is normal...used to happen before), I see the mouse pointer (busy cursor) on a blue background and within half a second or so, the screen mode changes back to a text one. Then apparently it tries to swith to a graphical mode a few more times before I finally get an error message in a box on the text mode (hope that makes sense).

Fe98 06-12-2004 04:11 PM

The error that I'm getting on startup is

Quote:

Failed to start the display server several times in a short period; disabling display :0

drigz 06-12-2004 05:33 PM

reinstall the nvidia drivers and all will be fine. to do this, just download the binary from nvidia.com. then, as root in console, run it. make sure you have the source for your kernel. how did you install the drivers in the first place?

this happens because the nvidia drivers work my making a module for the kernel which acts as the driver. however, when you get a new kernel, it cannot use modules made for the old one. this means you need to rerun the install to make a new module. you will need to do this after all new kernels.

edit: xf86config is a slackware thing i think. if you wanna use xconfigs, i think its xfree86setup is one, not sure baout the other.

Fe98 06-12-2004 05:39 PM

drigz, before I downloaded the new kernel I installed the drivers using the instructions supplied (first booting to init 3 and then building them, etc).

I started getting these problems after I installed the new kernel. I did try rebuilding the drivers and it seemed to work. (Actually, it said that I already have the drivers installed, built I rebuilt them anyway for the new kernel.)

So I'm still stuck here...

drigz 06-12-2004 05:46 PM

really? the problem looks exactly like what i have everytime i use a new kernel... after booting, try this:
modprobe nvidia
lsmod

and tell me the output.

edit: im going to bed ill check tomorrow.

Fe98 06-12-2004 05:48 PM

Ok when I ran modprobe nvidia I got the following output.

Warning: loading /lib/modules/2.4.20-31.9/kernel/drivers/video/nvidia.o will taint the kernel.

See http://www.tux.org/lkml/#export-tainted for information about tainted modules.

0: nvidia oading NVIDIA Linux x86 NVIDIA kernel module 1.0-5336 Wed Jan 14 18:29:26 PST 2004

module nvidia loaded, with warnings


I also ran lsmod and I got a long list of stuff. I didnt see nvidia as one of them though. It appeared that the output was longer than one screen so nvidia may have been output and I would have missed it (I don't know how to pause the output after each screen).

drigz 06-13-2004 03:18 AM

try running modprobe nvidia then startx.
if you want the output paused after each screen, run:
your command | less (or more or most or whatever you like)
if you want to search for some text in the output, run:
your command | grep 'text you want to search for'
and it will print every line in which the text appears.

Fe98 06-13-2004 10:19 AM

Ok I tried it again with basically the same results.

modprobe nvidia returns the same results that I had in my last post.

I then ran startx and it appeared that the video mode had changed, I saw the mouse cursor (an X) for a short while (less than a second) and then it changed back to text mode.

I got some error messages (warnings), too much to write out. Umm, I remember seeing something with Initializing GLX, and some warnings with GLib.

If I can't get it to work I'll just to a reinstall from scratch.

Oh, I forgot to add... lsmod | grep nvidia did return a single line ...

nvidia 2124384 0

drigz 06-13-2004 11:15 AM

do you know if you use xfree86 or x.org? im guessing that you have already removed the load "glcore" and load "dri" lines from your x config file.

Fe98 06-13-2004 04:21 PM

Umm, how do I find out? And yes I did remove both lines from the config file (and it worked on the previous kernel).

As a side point, when I try to boot up the old kernel I get the same errors.

drigz 06-13-2004 04:58 PM

does /etc/X11/xorg.conf exist? if so u use xorg and you need to edit that instead.

you could always try compiling a new kernel, booting (non-graphical) into that, installing the nvidia stuff and it might work.


All times are GMT -5. The time now is 10:24 PM.