-   Linux - Hardware (
-   -   Can't record Microphone input (

tmchardy 01-11-2006 03:56 PM

Can't record Microphone input
I'm having a problem with my microphone. I can't seem to record the input. I've tried both using a traditional recording program (krec) and the goal of the whole setup: TeamSpeak.

When i speak into the mic I'm getting audio coming out of my headphones, so I know the jack is plugged in correctly and sound is getting through, but nothing can seem to record it. I've played with as many settings as I can think of. Cranked all the KMix recording settings, tried using /dev/dsp and /dev/audio (I've very unfamiliar with the hardware devices and so don't know if there are others I can try or if these are even the right ones). I've even set permissions on these files to 777 to see if that helped.

I'm pretty stumped on this one and am looking for some advice in areas that I can look further.

MB: A8V Deluxe
Audio: Integrated board (don't know what model it shows up as)
Distro: FC4x64

cybrog 01-11-2006 04:31 PM

It might be worth looking in to JACK, a low-latency audio server, written for POSIX conformant operating systems such as GNU/Linux and Apple's OS X. It can connect a number of different applications to an audio device, as well as allowing them to share audio between themselves. Its clients can run in their own processes (ie. as normal applications), or can they can run within the JACK server (ie. as a "plugin").

tmchardy 01-12-2006 04:34 AM

I found out the answer... after everything I tried.
Turning everything on is bad...

In the mixer (kmix) turn everything OFF except microphone and capture. Apparently having the other input devices turned on has some sort of conflict and you get NOTHING! Yay!!! It works! :)

All times are GMT -5. The time now is 06:12 PM.