LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Can't print. connection to CUPS failed. (https://www.linuxquestions.org/questions/linux-hardware-18/cant-print-connection-to-cups-failed-556367/)

hacker supreme 05-24-2007 10:36 AM

Can't print. connection to CUPS failed.
 
My Samsung ML-2010 USB printer was working well until I tried to share it with a Windows box.
After giving up on being able to share it, I reset all the options I had changed back to their defaults.
However, I can't print anymore.

Going into printers in control centre as ordinary user tells me that the print system currently being used is localhost:631.
However, when I change to Administrator and put in the password, it then tells me that the print system being used is: /var/run/cup/cups.sock

Then an error message appears:
Quote:

Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running.
Error: /var/run/cups/cups/sock: read failed (14).
Please can someone help me fix this?

Okie 05-24-2007 11:15 AM

sounds like KDE was compiled without cups support built in properly, i roll my own KDE and use the parameter of --sysconfdir=/etc and KDE's printer config tool works good...

you can also configure cups by going to http://localhost:631 in a web browser...

hacker supreme 05-24-2007 12:01 PM

Thanks, I'll try that.
However, It's worked fine with KDE until now...

More info: Every time I send a job to the printer, it just sits there in the queue, marked processing.

hacker supreme 05-24-2007 12:12 PM

oh. And one more thing. Every time I try to set the printer up again. I get through the driver setup and click 'test' to print a test page.
This causes an error: 'Unable to create temporary printer'

And then, after that: 'Unable to create printer. Error message received from manager: client-error-bad-request'


All times are GMT -5. The time now is 06:24 AM.