-   Linux - Hardware (
-   -   Can't mount external storage after upgrading to Kubuntu 8.04 hardy (

BigFoot13 09-24-2009 10:46 AM

Can't mount external storage after upgrading to Kubuntu 8.04 hardy
Recently I upgraded from my long outdated Kubuntu 6.06 dapper installation to the new LTS, 8.04 hardy. Ever since everything has been working smoothly and going well, but there's one problem: I can't mount either my external USB HDD or my SD card in my USB card reader.

When I try to mount either in Konqueror (Media:/) by right clicking on the device and clicking Mount I get this:


mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error
In some cases useful info is found in syslog - try dmesg | tail or so

I also get this in the console:


mattmodica@Dothan:/media$ sudo mount sda1
[mntent]: warning: no final newline at the end of /etc/fstab
mount: can't find sda1 in /etc/fstab or /etc/mtab

The first method I tried (doing it in Konqueror) worked in dapper 6.06 just fine.

If I run dmesg | tail in console I get this:


mattmodica@Dothan:~$ dmesg | tail
[17254792.288000] sdc: assuming drive cache: write through
[17254792.316000] SCSI device sdc: 4001792 512-byte hdwr sectors (2049 MB)
[17254792.324000] sdc: Write Protect is off
[17254792.324000] sdc: Mode Sense: 38 00 00 00
[17254792.324000] sdc: assuming drive cache: write through
[17254792.324000]  sdc: sdc1
[17254792.348000] sd 3:0:0:1: Attached scsi removable disk sdc
[17254792.348000] sd 3:0:0:1: Attached scsi generic sg2 type 0
[17254792.360000] usb-storage: device scan complete
[17254800.736000] FAT: Unrecognized mount option "flush" or missing value

I'm just coming back to Linux now because out of luck a lot of stuff at college works in Linux. I'm still a little rusty though. Any help would be greatly appreciated.

amani 09-24-2009 11:24 AM

#sudo mkdir /media/disk
#sudo mount -t vfat /dev/sdc1 /media/disk

BigFoot13 09-24-2009 03:56 PM


Originally Posted by amani (Post 3695703)
#sudo mkdir /media/disk
#sudo mount -t vfat /dev/sdc1 /media/disk

Ahah! That did the trick. sdc1 was my card reader and sda1 was my HDD. Thanks!

BigFoot13 09-24-2009 04:20 PM

Ok, well one more issue. I think that root now owns my external media (since I used super user do to make the directories) and I can only read off it. Any way to change the permissions? Thanks

EDIT: I also can't umount it even as root. Something else is weird here...

All times are GMT -5. The time now is 04:38 AM.