LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-15-2003, 05:07 PM   #1
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
cant mount cdroms in slackware


Here's the deal:
I installed Slack 9.1 when it first came out a while ago, and I always had trouble with my cd burner and the ide-scsi emulation. I tried working around it with varying success. I got to the point where I wanted to get it working right, and also wanted to format and re-install slack. So, I formatted and set up ide-scsi emulation in the lilo config section of the install. Everything was fine, but when I ran Slack for the first time, it gives me this error when trying to mount my cdrom:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

I get this if I try to mount any cdrom I have. I know that this is the right device, and should be working. It was working before the format. I cant get around this and I cant use my cd-roms, so any help is needed and greatly appreciated.

Thanks,
Timeturtle
 
Old 11-16-2003, 10:51 AM   #2
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,318

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
I had problems with getting my CD-RW working using the SCSI emulation under Slackware 9.1 until I found that the position of the append=".... command in lilo.conf was crucial. Ensure that the append="... appears within the LILO global section.

.
.
# setup CD-RW scsi emulation
append="hdc=ide-scsi"
# End LILO global section
 
Old 11-16-2003, 10:58 AM   #3
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
If you compiled support as modules, they must be loaded:
Code:
Sun Nov 16 10:32am root@tinwhistle ~ # lsmod
Module                  Size  Used by    Not tainted
sg                     33924   0  (autoclean)
ide-scsi               11008   0 
scsi_mod              107596   2  [sg ide-scsi]
Is the burner configured and what is the device? Command this to find out:
cdrecord -scanbus
Adding an IDE CD-Writer to Linux
CD Writing HOWTO

Last edited by fancypiper; 11-16-2003 at 11:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount cdroms automatically? greythorne Arch 5 06-24-2005 05:52 PM
Reading cdroms without command mount unknown111 Linux - Software 2 07-21-2004 04:34 PM
i can't mount my cdroms Paxmaster Linux - Hardware 10 07-21-2004 10:40 AM
how do i mount CDroms and Floppy as root? BajaNick Linux - General 2 02-20-2004 12:18 AM
mandrake is trying to mount cdroms that dont exist lynnsbomb Mandriva 6 02-07-2004 05:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration