LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   cant mount cdroms in slackware (https://www.linuxquestions.org/questions/linux-hardware-18/cant-mount-cdroms-in-slackware-116447/)

Timeturtle 11-15-2003 05:07 PM

cant mount cdroms in slackware
 
Here's the deal:
I installed Slack 9.1 when it first came out a while ago, and I always had trouble with my cd burner and the ide-scsi emulation. I tried working around it with varying success. I got to the point where I wanted to get it working right, and also wanted to format and re-install slack. So, I formatted and set up ide-scsi emulation in the lilo config section of the install. Everything was fine, but when I ran Slack for the first time, it gives me this error when trying to mount my cdrom:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

I get this if I try to mount any cdrom I have. I know that this is the right device, and should be working. It was working before the format. I cant get around this and I cant use my cd-roms, so any help is needed and greatly appreciated.

Thanks,
Timeturtle

allend 11-16-2003 10:51 AM

I had problems with getting my CD-RW working using the SCSI emulation under Slackware 9.1 until I found that the position of the append=".... command in lilo.conf was crucial. Ensure that the append="... appears within the LILO global section.

.
.
# setup CD-RW scsi emulation
append="hdc=ide-scsi"
# End LILO global section

fancypiper 11-16-2003 10:58 AM

If you compiled support as modules, they must be loaded:
Code:

Sun Nov 16 10:32am root@tinwhistle ~ # lsmod
Module                  Size  Used by    Not tainted
sg                    33924  0  (autoclean)
ide-scsi              11008  0
scsi_mod              107596  2  [sg ide-scsi]

Is the burner configured and what is the device? Command this to find out:
cdrecord -scanbus
Adding an IDE CD-Writer to Linux
CD Writing HOWTO


All times are GMT -5. The time now is 07:33 AM.