-   Linux - Hardware (
-   -   can't locate module scanner > how to get scanner work? (

b0uncer 10-26-2003 07:37 AM

can't locate module scanner > how to get scanner work?
I've been working on my scanner today,'s Agfa SnapScan 1212u, which worked fine on RH. Well, now on gentoo, I have some problems..

First of all, the device file for my scanner is missing. I read somewhere that hotplug or something like it would possibly create this (?), and it should also load the appropriate module for me when I plug this thing on.

lsmod told me, that there are some usb-modules loaded but _no_ scanner modules. I tried to load one myself, but I only got the message: "modprobe: Can't locate module scanner"...

Information about my scanner is there. It's detected on boot as a usb-device, (but: "USB Device 2 is not claimed by any active driver) and

cat /proc/usb/devices

shows me that usb-device is Agfa SnapScan and a lot of other information...

So my system knows I do have a usb-scanner, and that it's Agfa Snapscan. So is the module "scanner" the only thing that is truly missing, and where can I get one? Shouldn't it be there already....?

If you have somekind of usb-device or scanner and think you could help me, please reply something...

b0uncer 10-26-2003 07:50 AM

oh,, I updated my kernel yesterday. seems like the "usb-scanner" was empty there (I used genkernel, didn't give a thought for what the "automatic" really means :) enabling it as a module should get this problem solved...or what..?

And one more thing. When re-compiling the kernel, to enable usb-scanner support, using menuconfig, what are the following steps? I can't remember them exactly....something like

make dep
make bzImage
make modules && make install modules

and then move the bzImage and kernel files to boot, or did I miss some step..?

All times are GMT -5. The time now is 02:37 AM.